Remote editing, tagging and similar tasks

Hi all,

I am running MusicBrainz Picard on a desktop computer which is on the same LAN (subnet) as the computer that holds all the music files. The desktop is running Linux Mint 19.1 Cinnamon and the remote machine Linux Mint 19.1 XFCE.

I would like to be able work, e.g. re-tagging, with those music files remotely from the main desktop PC and not directly on the music PC as it only offers an inconvenient 800x600 touch display (Thermaltake DH202) and there is no real place to sit.

SSH server is installed and running on the music PC and the desktop can successfully connect via SSH/SFTP to the music PC. So yes, I could copy the music back and forth but that seems more like a workaround than a proper fix or solution. A remote desktop session would also just be another workaround and depending on the software used for it only at 800x600.

Here’s my question: what do I need to do in MusicBrainz Picard to be able to access that remote machine, as when I try to access other devices, in this case a network device/share that CAN be reached over the LAN using e.g. SSH/SFTP by other applications, the music PC does neither show up nor do I seem to be able to provide a direct path to MusicBrainz Picard.

Thanks a lot in advance.:smiley:

Addendum: mea culpa. I didn’t expect others having similar challenges.
So from what I read setting up a Samba share (or NFS) should do the trick?
Any recommendations regarding setting it up? Thanks, again.

Samba or nfs can be used of course.

An alternative is to use sshfs (since you already have ssh set up):

sudo apt install sshfs
mkdir mountpoint
sshfs user@host:dir mountpoint

To unmount: fusermount -u mountpoint

To automount you’ll have to use autofs.

Googling for those should give you detailed instructions.


Super, Zas.

Helpful input and I’ll know that I’m not going to be looking in the “wrong” corners.


You can also use ssh and tunnel X to another computer.
Start a terminal and ssh to the remote server with the -x to allow you to run picard on the remote machine but show up on your computer.
ssh user@host -x -C picard

1 Like