Red tint on scans

Tags: #<Tag:0x00007f820b853678> #<Tag:0x00007f820b853358> #<Tag:0x00007f820b853218>

So I was scanning stuff for the CAA and suddenly my scanner started adding a red tint to everything. I have no idea what happened, I don’t think I changed any settings. Is there any way to fix this, or is this a sign that my scanner is kaput? :confused:

Comparison:

1 Like

It might be good to post a scan of an image that contains more colours, especially something displaying what ‘humans’ are good at, such as faces, trees, skies, a colourful scene, etc.

That might give a better clue to estimate if this maybe relates to e.g. an incorrect colour profile, or perhaps a specific defect with your scanner.

2 Likes

I’m not a technician but a tint of red usually means a lack of blue in RGB. Maybe there is a faulty contact somewhere if RGB information is transmitted in separate channels. Could also mean the lamp is about to give out. Changed colour profile is another possibility.

3 Likes

Here is a scan of https://www.waltons.ie/home/products/view/11awal-1376-long-the-waltons-guide-to-irish-music/ (which was the thing with the most range of colours I had readily available):


(I used the hub scans because those were two easily comparable scans made by the same scanner of images that should be virtually identical (other than matrix information).)

It seems the “preview” in XSane doesn’t distort the colours, even if the final scan does. I’ll try and figure out where XSane/sane stores its settings and I might try and just do a wholesale reset and see if that fixes anything. Edit: Moving ~/.sane out of the way did not change the scan result at all.

2 Likes

I’m not acquainted with this ‘XSane’, but you could perhaps do a test with the scanning software that came with your scanner?
That will probably give a clue if this is hard- or software related.

This is interesting. Can you make sure of this, maybe with comparing your result, zoomed out, to a preview screenshot.

Interesting indeed. I tried to scan with simple-scan and this doesn’t introduce this red tint:

However, this UI is not conducive for mass-scanning a bunch of cover art, so not a long-term solution. :frowning:

I tried with Skanlite too, but that had the same results as XSane, probably due to being just a different way to interface with sane.

Curious that resetting the SANE settings does not reset whatever colour calibration is going on. Maybe there are other data being stored somewhere that I didn’t find.

I got the scanner second-hand and I really can’t remember if I got any software with it. Regardless, even if there was software bundled, it would likely be Windows-only and not run under Linux. SANE is the way to deal with scanning under Linux.

2 Likes

Sane is great, I installed Linux instead of Windows 10, just for that!
I had to stay in Windows XP before discovering sane recently.
I hope you will find what can be done.
I don’t know enough yet to help.
But simple-scan is also using sane, with no options, so it’s strange that it does not bug. But it gives hope.