Red Circle "Not Permitted" sign

Tags: #<Tag:0x00007f820ae217b8> #<Tag:0x00007f820ae21538>

I ran Black Cherry by Goldfrapp through MBP. All seemed good. When I go to save, the type turns red and there is a red “not permitted” sign next to each track. I found some old topics from 2017 on the topic.
It indicates something went wrong while saving, I looked at the error log under “Help”

Stuff looks like this:
Traceback (most recent call last):
File “picard\util\thread.py”, line 60, in run
File “picard\file.py”, line 294, in _save_and_rename
File “picard\formats\vorbis.py”, line 309, in _save
File “site-packages\mutagen_util.py”, line 169, in wrapper
File “site-packages\mutagen_util.py”, line 139, in wrapper
File “contextlib.py”, line 112, in enter
File “site-packages\mutagen_util.py”, line 256, in _openfile
mutagen.MutagenError: [Errno 13] Permission denied: ‘L:\Goldfrapp\Black Cherry mp3\05 Deep Honey.flac’

If I go into my file explorer and check it out. It looks just fine.
The title indicates Mp3 files (not sure why) because the actual files are all FLAC I may have mis-named the folder at some previous time.

Are you sure the READ ONLY flag is not set? That’s what usually catches me out.

And as that is an L: drive - is it on the network? Try writing a notepad file in the folder just to be sure.

1 Like

I didn’t have full permissions. Something I still wrestle with in Windows. Even though I’m an admin. I only know enough to be dangerous to myself.

My day job includes Network Admin. So I can solve that for you with a few more details…

Is the L: drive on a Windows Network? And can you login to this PC fully as an admin allowing you change settings? If yes, I can point you at what to change.

The main thing to remember is you have to set TWO lots of rights. You need both FILE rights and SHARE rights to allow the user to Write.

Or just do as I do, install Picard on the File Server and edit the tags from that PC instead. :wink: The rest of my home network only has Read access to the music server to avoid accidental deletes.

1 Like

Eeeek! So many problems. I’m a limited admin (It’s my computer) as I mentioned earlier I know enough to make a mess.L: is just another drive on my machine. I should have left my account as Admin instead of creating a user account -which is what I work out of now. I continuouly run into files I can’t remove. Sometimes I’ve gone in and given permissions to everytning and still I’m told I don’t have admin rights. Thank you for your suggestions. Until I reinstall my OS I am forced to limp along.

1 Like

No, you are not forced to limp along. Just feed me some details and we will get the puzzle unlocked.

I am guessing Win10? If yes, then we can untangle this. There are different types of “admin rights” and being logged in as an admin is not the same as having rights to files.

Find your L: drive in Explorer and RIGHT CLICK on the root of the drive. Select PROPERTIES.

In the tabs that appear, select the SECURITY tab. It probably looks something like this:

image

Press that EDIT button and type in your admin username and password when asked.
This page now appears:
image

Now HIGHLIGHT Users and tick the box for FULL CONTROL in the Allow column.

Make sure all the ticks are in that Allow column, nothing in Deny column.

If this is just music drive it would be a good idea to also make sure Authenticated Users and Administrators also have a full set of ticks in Allow.

Now hit OK and let me know what happens. If you hit errors about Ownership, we have another step to do. If no errors, then you should be good to go.

Ask questions and I will simplify where possible.

4 Likes

Win 7 Ultimate sp1. I’ll follow your diagrams. I seem to have to add users to get anything to do anything. Even then, it doesn’t work 90% of the time.

System and Administraotors both have all the “allow columns” checked.
Authenticated user “full control” is not checked. User “Full control” and “modify” not checked
I’ve checked everything for those two. Now it rips through all my files giving me rights…it only works because you’re watching

I frequently fight with one folder somewhere that tells me I dont have rights. Of course now that folder is hiding. Thank you for your help and advice.

2 Likes

Excellent. Good to see it work. I have been manipulating these file rights since the days of NT 3.5 back in the Previous Century. I am used to the Strange Ways and understand the Black Magics. :wink:

Stash the notes you have here and it will be a memory jog next time. Any more file rights \ sharing rights issues then please do come back and just post questions here and I’ll assist. I have the Magic Hammers of Persuasion™ and will help assist to get back the folders you need access to. There are other tricks up this sleeve.

3 Likes

Thanks @IvanDobsky , had the same problem on one of my 10 machines. This fixed it.

2 Likes