Random genres being entered


#1

I am using a Mac with High Sierra and the most up to date Picard. I keep getting the worst genres tagged to my files. I don’t have the Last FM plugin enabled or the wikigenre one or folksknomoy and yet my files are getting tagged with different short genre tags like dan; trance; electronic; jaz for random songs on albums too. I don’t have any separate scripts running relating to genre either. What am I screwing up? Thank you for your help.


#2

Picard itself does not write any genre tag unless you have “Use folksonomy tags as genres” enabled. If this is off, it must be a plugin. Which ones do you have enabled? Try disabling them all.

Last possibility is that the tags are already present in the files. Have a look at the original tag value in the bottom left, is genre already set there? If so you can either manually remove it or you activate the “Clear existing tags” option. Be careful with the last one, it removes all the tags including cover art and only saves again what Picard provides.


#3

“dan” and “jaz” sound like one of the two AcousticBrainz plugins – one of them adds the calculated BPM and key, and generally works decently well, the other adds calculated genres and isn’t quite as predictable. I don’t remember exactly what each are called, but you might want to check them to be sure the latter is disabled.


#4

Thank you both. I think WovenTales was right. I had disabled the plugins and clicked “make it so” but for some reason on High Sierra Picard would not actually keep the settings but I got it figure out by deleting all the plugins.