Problem with local bookbrainz install: npm error

I tried to setup my own bookbrainz server on a Fedora 32. I could solve some of the problems but now got stucked at step 21 npm install. I enabled verbose to the command and this is the output:

How can I proceed? I searched for the error and on some sites it was told to switch to another version of npm. But I’m totally new to docker and have no glue what to do.

Thanks for helping

Hi Madir!

So you are running everything in docker?
If so, the issue is unlikely to be with your OS or NPM version, since Node and NPM versions are defined by the docker image definition, meaning everyone using docker will be running the same version.

What steps did you take to get there? Just running the ./ command?
Could you please send the entirety of your log (in something like for example)? There might be a useful clue in there to find.

Have you tried building the image again? It could have been a temporary issue.
Is could also potentially be something to do with your internet connection or a proxy.

To try and isolate the issue, you could try building another Node-based docker image to see if it fails in the same way. Here’s a random project that uses technologies similar to BookBrainz; clone the project then from that folder run the command docker build ..

I couldn’t even reach the state, where ./ should be called. It is the step 21 of ./scripts/ which fails.

I switched to debain (not my favourite but ok) and everything is working. So I guess as Fedora always uses the latest of everything something is not compatible. I already removed this virtual machine, but if I ever set up a new one, I’ll test it again.

1 Like