Problem while starting the web server after building

Hello, I am Sweta Vooda currently pursuing bachelors in Information Technology.

I would like to contribute to this organisation and participate in GSOC 2020.

I am facing a problem while starting the webserver to run using the ./develop.sh up command, I followed all the steps mentioned in the documentation It’s taking more than 3 hours to start the web server and displays a message dataset_evaluator_1 | 2020-02-27 17:20:37,850 - INFO - No pending datasets. Sleeping 30 seconds. every 30 seconds and doesn’t end.

It would be helpful if anyone can help me fix this issue and run the site successfully so that I can start working on some tickets.

Also, I have decided to work on this ticket and commented some doubts I have regarding the issue.

I would be grateful if someone could guide me through the issue and help me work on the it.
Looking forward to some great contributions.

Hi Sweta,
The message “No pending datasets. Sleeping 30 seconds.” is not an error. When the AcousticBrainz website starts it loads about 6 different processes (database servers, webserver, dataset evaluator). This message is just a log message saying that the dataset evaluator is running and waiting for work.

When you get the log message webserver_1 | INFO:werkzeug * Running on http://0.0.0.0:8000, this indicates the webserver is up and running.

I’m less sure about the error message that finished with “Exec format error”. This seems to indicate that there is a problem with the architecture of some dependency that was installed. Was there a specific thing that you did before this error occurred, or does it come up after you run ./develop.sh up? Can you tell me what versions of these

  • Version of Windows (home/pro, 32bit or 64bit)
  • Version of docker
  • commands you ran to build acousticbrainz

Can you please copy the full output that you get after you run ./develop.sh up? It’s better to paste it as text instead of sending an image. It looks like there are probably some additional error messages which you didn’t add in this message.

1 Like

Thank you for letting me know, it was my bad that I didn’t check the error properly. I tried running the server and it didn’t work so I assumed the error was with the pending datasets.

The error came up after running the ./develop.sh up command, I followed the commands which were mentioned in the documentation.

Version of Windows:
OS Name Microsoft Windows 10 Home
Version 10.0.18362 Build 18362

Docker version 19.03.1, build 74b1e89e8a

Commands I ran to build AcousticBrainz server:

./develop.sh build

./develop.sh run --rm webserver python2 manage.py init_db

./develop.sh up

As my Windows is not Pro, I had to download the Docker Toolbox instead which comes with the docker-compose and virtual box. For this, I had to enable virtualisation in BIOS.

Here is the output I got after running the command.

acousticbrainz-server_db_1 is up-to-date
acousticbrainz-server_redis_1 is up-to-date
acousticbrainz-server_hl_extractor_1 is up-to-date
acousticbrainz-server_dataset_evaluator_1 is up-to-date
Starting acousticbrainz-server_webserver_1 ... done                                                                                                                         Attaching to acousticbrainz-server_db_1, acousticbrainz-server_redis_1, acousticbrainz-server_hl_extractor_1, acousticbrainz-server_dataset_evaluator_1, acousticbrainz-server_webserver_1
db_1                 | The files belonging to this database system will be owned by user "postgres".
db_1                 | This user must also own the server process.
db_1                 |
db_1                 | The database cluster will be initialized with locale "en_US.utf8".
db_1                 | The default database encoding has accordingly been set to "UTF8".
db_1                 | The default text search configuration will be set to "english".
db_1                 |
db_1                 | Data page checksums are disabled.
db_1                 |
db_1                 | fixing permissions on existing directory /var/lib/postgresql/data ... ok
db_1                 | creating subdirectories ... ok
db_1                 | selecting default max_connections ... 100
db_1                 | selecting default shared_buffers ... 128MB
db_1                 | selecting dynamic shared memory implementation ... posix
db_1                 | creating configuration files ... ok
db_1                 | running bootstrap script ... ok
db_1                 | performing post-bootstrap initialization ... ok
db_1                 | syncing data to disk ... ok
db_1                 |
db_1                 | WARNING: enabling "trust" authentication for local connections
db_1                 | You can change this by editing pg_hba.conf or using the option -A, or
db_1                 | --auth-local and --auth-host, the next time you run initdb.
db_1                 |
db_1                 | Success. You can now start the database server using:
db_1                 |
db_1                 |     pg_ctl -D /var/lib/postgresql/data -l logfile start
db_1                 |
db_1                 | ****************************************************
db_1                 | WARNING: No password has been set for the database.
db_1                 |          This will allow anyone with access to the
db_1                 |          Postgres port to access your database. In
db_1                 |          Docker's default configuration, this is
db_1                 |          effectively any other container on the same
db_1                 |          system.
db_1                 |
db_1                 |          Use "-e POSTGRES_PASSWORD=password" to set
db_1                 |          it in "docker run".
db_1                 | ****************************************************
db_1                 | waiting for server to start....2020-02-26 15:04:59.794 UTC [40] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
db_1                 | 2020-02-26 15:04:59.825 UTC [41] LOG:  database system was shut down at 2020-02-26 15:04:59 UTC
db_1                 | 2020-02-26 15:04:59.839 UTC [40] LOG:  database system is ready to accept connections
db_1                 |  done
db_1                 | server started
db_1                 |
db_1                 | /usr/local/bin/docker-entrypoint.sh: ignoring /docker-entrypoint-initdb.d/*
db_1                 |
db_1                 | 2020-02-26 15:04:59.860 UTC [40] LOG:  received fast shutdown request
db_1                 | waiting for server to shut down....2020-02-26 15:04:59.863 UTC [40] LOG:  aborting any active transactions
db_1                 | 2020-02-26 15:04:59.885 UTC [40] LOG:  worker process: logical replication launcher (PID 47) exited with exit code 1
db_1                 | 2020-02-26 15:04:59.886 UTC [42] LOG:  shutting down
db_1                 | 2020-02-26 15:04:59.908 UTC [40] LOG:  database system is shut down
db_1                 |  done
db_1                 | server stopped
db_1                 |
db_1                 | PostgreSQL init process complete; ready for start up.
db_1                 |
db_1                 | 2020-02-26 15:05:00.032 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
db_1                 | 2020-02-26 15:05:00.032 UTC [1] LOG:  listening on IPv6 address "::", port 5432
db_1                 | 2020-02-26 15:05:00.036 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
db_1                 | 2020-02-26 15:05:00.082 UTC [49] LOG:  database system was shut down at 2020-02-26 15:04:59 UTC
db_1                 | 2020-02-26 15:05:00.107 UTC [1] LOG:  database system is ready to accept connections
db_1                 | 2020-02-26 15:05:02.692 UTC [59] WARNING:  there is already a transaction in progress
db_1                 | 2020-02-26 15:05:02.794 UTC [59] WARNING:  there is no transaction in progress
db_1                 | 2020-02-26 15:05:02.815 UTC [60] WARNING:  there is already a transaction in progress
db_1                 | 2020-02-26 15:05:02.822 UTC [60] WARNING:  there is no transaction in progress
db_1                 | 2020-02-26 15:05:02.832 UTC [61] WARNING:  there is already a transaction in progress
db_1                 | 2020-02-26 15:05:02.866 UTC [61] WARNING:  there is no transaction in progress
db_1                 | 2020-02-26 15:05:02.890 UTC [62] WARNING:  there is already a transaction in progress
db_1                 | 2020-02-26 15:05:02.931 UTC [62] WARNING:  there is no transaction in progress
db_1                 | 2020-02-26 15:05:02.946 UTC [64] WARNING:  there is already a transaction in progress
db_1                 | 2020-02-26 15:05:02.979 UTC [64] WARNING:  there is no transaction in progress
db_1                 | 2020-02-27 13:06:25.215 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
db_1                 | 2020-02-27 13:06:25.215 UTC [1] LOG:  listening on IPv6 address "::", port 5432
db_1                 | 2020-02-27 13:06:25.218 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
db_1                 | 2020-02-27 13:06:25.282 UTC [21] LOG:  database system was interrupted; last known up at 2020-02-26 15:10:22 UTC
db_1                 | 2020-02-27 13:06:25.559 UTC [21] LOG:  database system was not properly shut down; automatic recovery in progress
db_1                 | 2020-02-27 13:06:25.561 UTC [21] LOG:  redo starts at 0/1726138
db_1                 | 2020-02-27 13:06:25.562 UTC [21] LOG:  invalid record length at 0/1726218: wanted 24, got 0
db_1                 | 2020-02-27 13:06:25.563 UTC [21] LOG:  redo done at 0/17261E0
db_1                 | 2020-02-27 13:06:25.611 UTC [1] LOG:  database system is ready to accept connections
db_1                 | 2020-02-27 13:14:32.077 UTC [70] ERROR:  role "acousticbrainz" already exists
db_1                 | 2020-02-27 13:14:32.077 UTC [70] STATEMENT:  CREATE USER acousticbrainz NOCREATEDB NOSUPERUSER;
db_1                 | 2020-02-28 13:34:52.212 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
db_1                 | 2020-02-28 13:34:52.213 UTC [1] LOG:  listening on IPv6 address "::", port 5432
db_1                 | 2020-02-28 13:34:52.218 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
db_1                 | 2020-02-28 13:34:52.263 UTC [21] LOG:  database system was interrupted; last known up at 2020-02-27 13:06:25 UTC
db_1                 | 2020-02-28 13:34:52.528 UTC [21] LOG:  database system was not properly shut down; automatic recovery in progress
db_1                 | 2020-02-28 13:34:52.530 UTC [21] LOG:  redo starts at 0/1726288
db_1                 | 2020-02-28 13:34:52.534 UTC [21] LOG:  invalid record length at 0/17262C0: wanted 24, got 0
db_1                 | 2020-02-28 13:34:52.534 UTC [21] LOG:  redo done at 0/1726288
db_1                 | 2020-02-28 13:34:52.572 UTC [1] LOG:  database system is ready to accept connections
db_1                 | 2020-02-28 15:49:05.370 UTC [371] ERROR:  role "acousticbrainz" already exists
db_1                 | 2020-02-28 15:49:05.370 UTC [371] STATEMENT:  CREATE USER acousticbrainz NOCREATEDB NOSUPERUSER;
redis_1              | 1:C 26 Feb 15:04:52.569 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1              | 1:C 26 Feb 15:04:52.570 # Redis version=4.0.14, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1              | 1:C 26 Feb 15:04:52.570 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
redis_1              | 1:M 26 Feb 15:04:52.579 * Running mode=standalone, port=6379.
redis_1              | 1:M 26 Feb 15:04:52.580 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1              | 1:M 26 Feb 15:04:52.580 # Server initialized
redis_1              | 1:M 26 Feb 15:04:52.581 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1              | 1:M 26 Feb 15:04:52.582 * Ready to accept connections
redis_1              | 1:M 26 Feb 16:04:53.018 * 1 changes in 3600 seconds. Saving...
redis_1              | 1:M 26 Feb 16:04:53.020 * Background saving started by pid 12
redis_1              | 12:C 26 Feb 16:04:53.026 * DB saved on disk
redis_1              | 12:C 26 Feb 16:04:53.028 * RDB: 0 MB of memory used by copy-on-write
redis_1              | 1:M 26 Feb 16:04:53.123 * Background saving terminated with success
redis_1              | 1:M 26 Feb 17:46:11.215 * 1 changes in 3600 seconds. Saving...
redis_1              | 1:M 26 Feb 17:46:11.215 * Background saving started by pid 13
redis_1              | 13:C 26 Feb 17:46:11.218 * DB saved on disk
redis_1              | 13:C 26 Feb 17:46:11.218 * RDB: 0 MB of memory used by copy-on-write
redis_1              | 1:M 26 Feb 17:46:11.316 * Background saving terminated with success
redis_1              | 1:C 27 Feb 13:06:24.697 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1              | 1:C 27 Feb 13:06:24.697 # Redis version=4.0.14, bits=64, commit=00000000, modified=0, pid=1, just started
dataset_evaluator_1  | 2020-02-28 15:49:36,976 - INFO - Raven is not configured (logging is disabled). Please see the documentation for more information.
redis_1              | 1:C 27 Feb 13:06:24.697 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
redis_1              | 1:M 27 Feb 13:06:24.705 * Running mode=standalone, port=6379.
redis_1              | 1:M 27 Feb 13:06:24.705 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
dataset_evaluator_1  | /usr/local/lib/python2.7/site-packages/psycopg2/__init__.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use "pip install psycopg2-binary" instead. For details see: <http://initd.org/psycopg/docs/install.html#binary-install-from-pypi>.
redis_1              | 1:M 27 Feb 13:06:24.705 # Server initialized
dataset_evaluator_1  |   """)
dataset_evaluator_1  | 2020-02-28 15:49:37,617 - INFO - Starting dataset evaluator...
dataset_evaluator_1  | 2020-02-28 15:49:37,648 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:50:07,681 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 27 Feb 13:06:24.706 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
dataset_evaluator_1  | 2020-02-28 15:50:37,715 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 27 Feb 13:06:24.707 * DB loaded from disk: 0.001 seconds
dataset_evaluator_1  | 2020-02-28 15:51:07,749 - INFO - No pending datasets. Sleeping 30 seconds.
hl_extractor_1       | 2020-02-28 15:49:28,180 - INFO - Raven is not configured (logging is disabled). Please see the documentation for more information.
redis_1              | 1:M 27 Feb 13:06:24.707 * Ready to accept connections
redis_1              | 1:M 27 Feb 14:06:25.027 * 1 changes in 3600 seconds. Saving...
redis_1              | 1:M 27 Feb 14:06:25.030 * Background saving started by pid 12
redis_1              | 12:C 27 Feb 14:06:25.036 * DB saved on disk
dataset_evaluator_1  | 2020-02-28 15:51:37,800 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 12:C 27 Feb 14:06:25.040 * RDB: 0 MB of memory used by copy-on-write
hl_extractor_1       | /usr/local/lib/python2.7/site-packages/psycopg2/__init__.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use "pip install psycopg2-binary" instead. For details see: <http://initd.org/psycopg/docs/install.html#binary-install-from-pypi>.
dataset_evaluator_1  | 2020-02-28 15:52:07,845 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 27 Feb 14:06:25.133 * Background saving terminated with success
redis_1              | 1:C 28 Feb 13:34:51.672 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
dataset_evaluator_1  | 2020-02-28 15:52:37,860 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:53:07,913 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:53:37,947 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:54:07,961 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:54:37,996 - INFO - No pending datasets. Sleeping 30 seconds.
hl_extractor_1       |   """)
dataset_evaluator_1  | 2020-02-28 15:55:08,034 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:C 28 Feb 13:34:51.672 # Redis version=4.0.14, bits=64, commit=00000000, modified=0, pid=1, just started
dataset_evaluator_1  | 2020-02-28 15:55:38,072 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:C 28 Feb 13:34:51.672 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
hl_extractor_1       | High-level extractor daemon starting with 1 threads
dataset_evaluator_1  | 2020-02-28 15:56:08,122 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 13:34:51.687 * Running mode=standalone, port=6379.
redis_1              | 1:M 28 Feb 13:34:51.687 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
dataset_evaluator_1  | 2020-02-28 15:56:38,133 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 13:34:51.688 # Server initialized
redis_1              | 1:M 28 Feb 13:34:51.688 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1              | 1:M 28 Feb 13:34:51.690 * DB loaded from disk: 0.001 seconds
dataset_evaluator_1  | 2020-02-28 15:57:08,180 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:57:38,225 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 13:34:51.690 * Ready to accept connections
redis_1              | 1:M 28 Feb 14:34:52.005 * 1 changes in 3600 seconds. Saving...
dataset_evaluator_1  | 2020-02-28 15:58:08,263 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 14:34:52.006 * Background saving started by pid 12
dataset_evaluator_1  | 2020-02-28 15:58:38,310 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 15:59:08,355 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 12:C 28 Feb 14:34:52.008 * DB saved on disk
dataset_evaluator_1  | 2020-02-28 15:59:38,407 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 12:C 28 Feb 14:34:52.009 * RDB: 0 MB of memory used by copy-on-write
redis_1              | 1:M 28 Feb 14:34:52.107 * Background saving terminated with success
dataset_evaluator_1  | 2020-02-28 16:00:08,441 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:00:38,486 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:signal-handler (1582900631) Received SIGTERM scheduling shutdown...
dataset_evaluator_1  | 2020-02-28 16:01:08,508 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:01:38,561 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 14:37:11.165 # User requested shutdown...
dataset_evaluator_1  | 2020-02-28 16:02:08,606 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 14:37:11.165 * Saving the final RDB snapshot before exiting.
redis_1              | 1:M 28 Feb 14:37:11.166 * DB saved on disk
redis_1              | 1:M 28 Feb 14:37:11.166 # Redis is now ready to exit, bye bye...
dataset_evaluator_1  | 2020-02-28 16:02:38,647 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:03:08,669 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:C 28 Feb 15:49:02.373 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
dataset_evaluator_1  | 2020-02-28 16:03:38,714 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:C 28 Feb 15:49:02.376 # Redis version=4.0.14, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1              | 1:C 28 Feb 15:49:02.377 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
dataset_evaluator_1  | 2020-02-28 16:04:08,750 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 15:49:02.380 * Running mode=standalone, port=6379.
dataset_evaluator_1  | 2020-02-28 16:04:38,801 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:05:08,842 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 15:49:02.380 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
dataset_evaluator_1  | 2020-02-28 16:05:38,875 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 15:49:02.381 # Server initialized
dataset_evaluator_1  | 2020-02-28 16:06:08,934 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 15:49:02.382 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
dataset_evaluator_1  | 2020-02-28 16:06:38,973 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 15:49:02.382 * DB loaded from disk: 0.000 seconds
redis_1              | 1:M 28 Feb 15:49:02.383 * Ready to accept connections
dataset_evaluator_1  | 2020-02-28 16:07:09,008 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:07:39,030 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:08:09,098 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 16:49:03.029 * 1 changes in 3600 seconds. Saving...
dataset_evaluator_1  | 2020-02-28 16:08:39,138 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 16:49:03.030 * Background saving started by pid 12
redis_1              | 12:C 28 Feb 16:49:03.033 * DB saved on disk
dataset_evaluator_1  | 2020-02-28 16:09:09,176 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:09:39,220 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 12:C 28 Feb 16:49:03.034 * RDB: 0 MB of memory used by copy-on-write
redis_1              | 1:M 28 Feb 16:49:03.139 * Background saving terminated with success
dataset_evaluator_1  | 2020-02-28 16:10:09,261 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:10:39,309 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:11:09,353 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:11:39,385 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:12:09,405 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:12:39,441 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:13:09,466 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:13:39,500 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:14:09,529 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:14:39,592 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:15:09,669 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 16:15:39,713 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 17:51:47,552 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 17:52:17,603 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 17:52:47,702 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 17:53:17,788 - INFO - No pending datasets. Sleeping 30 seconds.
dataset_evaluator_1  | 2020-02-28 17:53:47,830 - INFO - No pending datasets. Sleeping 30 seconds.
redis_1              | 1:M 28 Feb 17:54:13.691 * 1 changes in 3600 seconds. Saving...
redis_1              | 1:M 28 Feb 17:54:13.691 * Background saving started by pid 13
redis_1              | 13:C 28 Feb 17:54:13.694 * DB saved on disk
redis_1              | 13:C 28 Feb 17:54:13.694 * RDB: 0 MB of memory used by copy-on-write
redis_1              | 1:M 28 Feb 17:54:13.793 * Background saving terminated with success
webserver_1          | /usr/local/lib/python2.7/site-packages/psycopg2/__init__.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use "pip install psycopg2-binary" instead. For details see: <http://initd.org/psycopg/docs/install.html#binary-install-from-pypi>.
webserver_1          |   """)
webserver_1          |  * Environment: development
webserver_1          |  * Debug mode: on
webserver_1          | INFO:werkzeug: * Running on http://0.0.0.0:8080/ (Press CTRL+C to quit)
webserver_1          | INFO:werkzeug: * Restarting with stat
webserver_1          | Traceback (most recent call last):
webserver_1          |   File "manage.py", line 318, in <module>
webserver_1          |     cli()
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 764, in __call__
webserver_1          |     return self.main(*args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/flask/cli.py", line 557, in main
webserver_1          |     return super(FlaskGroup, self).main(*args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 717, in main
webserver_1          |     rv = self.invoke(ctx)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 1137, in invoke
webserver_1          |     return _process_result(sub_ctx.command.invoke(sub_ctx))
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 956, in invoke
webserver_1          |     return ctx.invoke(self.callback, **ctx.params)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 555, in invoke
webserver_1          |     return callback(*args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/decorators.py", line 17, in new_func
webserver_1          |     return f(get_current_context(), *args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/flask/cli.py", line 412, in decorator
webserver_1          |     return __ctx.invoke(f, *args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 555, in invoke
webserver_1          |     return callback(*args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/decorators.py", line 64, in new_func
webserver_1          |     return ctx.invoke(f, obj, *args, **kwargs)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/click/core.py", line 555, in invoke
webserver_1          |     return callback(*args, **kwargs)
webserver_1          |   File "manage.py", line 64, in runserver
webserver_1          |     extra_files=reload_on_files)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/werkzeug/serving.py", line 988, in run_simple
webserver_1          |     run_with_reloader(inner, extra_files, reloader_interval, reloader_type)
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/werkzeug/_reloader.py", line 332, in run_with_reloader
webserver_1          |     sys.exit(reloader.restart_with_reloader())
webserver_1          |   File "/usr/local/lib/python2.7/site-packages/werkzeug/_reloader.py", line 176, in restart_with_reloader
webserver_1          |     exit_code = subprocess.call(args, env=new_environ, close_fds=False)
webserver_1          |   File "/usr/local/lib/python2.7/subprocess.py", line 172, in call
webserver_1          |     return Popen(*popenargs, **kwargs).wait()
webserver_1          |   File "/usr/local/lib/python2.7/subprocess.py", line 394, in __init__
webserver_1          |     errread, errwrite)
webserver_1          |   File "/usr/local/lib/python2.7/subprocess.py", line 1047, in _execute_child
webserver_1          |     raise child_exception
webserver_1          | OSError: [Errno 8] Exec format error
acousticbrainz-server_webserver_1 exited with code 1
dataset_evaluator_1  | 2020-02-28 17:54:17,889 - INFO - No pending datasets. Sleeping 30 seconds.

Also, I tried checking why this problem was occurring and the surprisingly none of my localhosts are working may be due to some network issue or because of the virtual box. I am not sure about this.

Here are the images that got created

This is a really interesting bug. Unfortunately I’m not sure what’s causing it.
It doesn’t look like it’s related to network settings. My guess from the Exec format error message is that there’s a problem with 32bit/64bit settings in your virtual machine - although I’m surprised that you manage to run some services (such as the dataset_evaluator), but not others.

Can you confirm that your virtual machine in virtualbox is configured to be 64 bit, and not 32 bit?

Can you try and run these commands and see if you get the same output as me:

$ ./develop.sh run --rm webserver bash
Starting acousticbrainz-server_db_1    ... done
Starting acousticbrainz-server_redis_1 ... done
root@9a24ed0a7e48:/code# which python
/usr/local/bin/python
root@9a24ed0a7e48:/code# which python2
/usr/local/bin/python2
root@9a24ed0a7e48:/code# ls -l /usr/local/bin/python
lrwxrwxrwx 1 root root 7 Mar  2  2019 /usr/local/bin/python -> python2
root@9a24ed0a7e48:/code# ls -l /usr/local/bin/python2
lrwxrwxrwx 1 root root 9 Mar  2  2019 /usr/local/bin/python2 -> python2.7
root@9a24ed0a7e48:/code# ls -l /usr/local/bin/python2.7
-rwxr-xr-x 1 root root 11576 Mar  2  2019 /usr/local/bin/python2.7
root@9a24ed0a7e48:/code# file /usr/local/bin/python2.7
/usr/local/bin/python2.7: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=09ad183274c84a305cb8131a36f27e10475e4d6f, not stripped
root@9a24ed0a7e48:/code# /usr/local/bin/python2.7
Python 2.7.15 (default, Mar  2 2019, 11:09:46)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> exit()
root@9a24ed0a7e48:/code# ls -l /usr/bin/python
lrwxrwxrwx 1 root root 9 Nov 24  2017 /usr/bin/python -> python2.7
root@9a24ed0a7e48:/code# file /usr/bin/python2.7
/usr/bin/python2.7: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=901ede4524faa7d2d0842deb410e336e32da38d0, stripped
root@9a24ed0a7e48:/code# /usr/bin/python2.7
Python 2.7.12 (default, Oct  8 2019, 14:14:10)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> exit()
root@9a24ed0a7e48:/code#

@alastairp thank you for your patience, even I am struggling to find out the problem.
I checked my virtual machine and it is configured to be 64bit.
Here is a pic.


Also, I tried running all the given commands and seems like I got the same output.
here is my output.

Starting acousticbrainz-server_db_1 ... done                                                                            Starting acousticbrainz-server_redis_1 ... done                                                                         root@4044f861e8ff:/code# which python
/usr/local/bin/python
root@4044f861e8ff:/code# which python2
/usr/local/bin/python2
root@4044f861e8ff:/code# ls -l /usr/local/bin/python
lrwxrwxrwx 1 root root 7 Mar  2  2019 /usr/local/bin/python -> python2
root@4044f861e8ff:/code# ls -l /usr/local/bin/python2
lrwxrwxrwx 1 root root 9 Mar  2  2019 /usr/local/bin/python2 -> python2.7
root@4044f861e8ff:/code# ls -l /usr/local/bin/python2.7
-rwxr-xr-x 1 root root 11576 Mar  2  2019 /usr/local/bin/python2.7
root@4044f861e8ff:/code# file  /usr/local/bin/python2.7
/usr/local/bin/python2.7: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=09ad183274c84a305cb8131a36f27e10475e4d6f, not stripped
root@4044f861e8ff:/code# /usr/local/bin/python2.7
Python 2.7.15 (default, Mar  2 2019, 11:09:46)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> exit()
root@4044f861e8ff:/code# ls -l /usr/bin/python
lrwxrwxrwx 1 root root 9 Nov 24  2017 /usr/bin/python -> python2.7
root@4044f861e8ff:/code# file /usr/bin/python2.7
/usr/bin/python2.7: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=901ede4524faa7d2d0842deb410e336e32da38d0, stripped
root@4044f861e8ff:/code# /usr/bin/python2.7
Python 2.7.12 (default, Oct  8 2019, 14:14:10)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> exit()

Somehow I feel it is because of some network settings because none of my other images is shown in the localhost although they are running( maybe my Docker is not able to map the ports to localhost).
I tried multiple things to run the site and many people have reported such bugs with windows. Maybe it is a problem with Windows not sure how to solve this issue.

Can you try the following 2 steps:

In the file docker/docker-compose.dev.yml on line 27, replace the text FLASK_ENV: development with FLASK_ENV: testing. Run ./develop.sh up again. When I do this, I get the following output:

webserver_1          |  * Environment: testing
webserver_1          |  * Debug mode: off
webserver_1          | INFO:werkzeug: * Running on http://0.0.0.0:8080/ (Press CTRL+C to quit)

This means that the flask reloader isn’t running (which is the part which seems to be the part causing your error).
If this works, try the following:

Restore the text to FLASK_ENV: development
Change line 28 (command) to command: flask run. When I do this, my output is:

webserver_1          |  * Environment: development
webserver_1          |  * Debug mode: on
webserver_1          |  * Running on http://127.0.0.1:5000/ (Press CTRL+C to quit)
webserver_1          |  * Restarting with stat
webserver_1          |  * Debugger is active!
webserver_1          |  * Debugger PIN: 623-389-487

You may have to do something with virtualbox port forwarding to be able to access the application when it’s running. Unfortunately, I don’t know anything about these tools or Docker toolbox, so I’m unable to help here.

1 Like

Hello, i have the same problem, here is the output from the up command

Starting acousticbrainz-server_db_1 … done
Starting acousticbrainz-server_redis_1 … done
Starting acousticbrainz-server_hl_extractor_1 … done
Starting acousticbrainz-server_dataset_evaluator_1 … done
Starting acousticbrainz-server_webserver_1 … done
Attaching to acousticbrainz-server_redis_1, acousticbrainz-server_db_1, acousticbrainz-server_hl_extractor_1, acousticbrainz-server_webserver_1, acousticbrainz-server_dataset_evaluator_1
db_1 | 2020-03-05 14:05:33.777 UTC [1] LOG: listening on IPv4 address “0.0.0.0”, port 5432
db_1 | 2020-03-05 14:05:33.777 UTC [1] LOG: listening on IPv6 address “::”, port 5432
db_1 | 2020-03-05 14:05:33.784 UTC [1] LOG: listening on Unix socket “/var/run/postgresql/.s.PGSQL.5432”
db_1 | 2020-03-05 14:05:33.885 UTC [22] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:33.888 UTC [23] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:33.893 UTC [21] LOG: database system was shut down at 2020-03-05 14:05:25 UTC
db_1 | 2020-03-05 14:05:33.898 UTC [24] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:33.903 UTC [1] LOG: database system is ready to accept connections
db_1 | 2020-03-05 14:05:34.653 UTC [31] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:34.685 UTC [32] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:34.725 UTC [33] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:34.790 UTC [34] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:34.933 UTC [36] LOG: invalid length of startup packet
redis_1 | 1:C 05 Mar 14:05:33.552 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 14:05:33.552 # Redis version=4.0.14, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 14:05:33.552 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
redis_1 | 1:M 05 Mar 14:05:33.554 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 14:05:33.554 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 14:05:33.554 # Server initialized
redis_1 | 1:M 05 Mar 14:05:33.554 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 14:05:33.554 * DB loaded from disk: 0.000 seconds
redis_1 | 1:M 05 Mar 14:05:33.554 * Ready to accept connections
db_1 | 2020-03-05 14:05:34.934 UTC [35] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:35.661 UTC [37] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:35.691 UTC [38] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:35.732 UTC [39] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:35.795 UTC [40] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:35.940 UTC [41] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:35.979 UTC [42] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:36.698 UTC [43] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:36.801 UTC [44] LOG: invalid length of startup packet
hl_extractor_1 | 2020-03-05 14:05:36,900 - INFO - Raven is not configured (logging is disabled). Please see the documentation for more information.
db_1 | 2020-03-05 14:05:36.947 UTC [45] LOG: invalid length of startup packet
webserver_1 | /usr/local/lib/python2.7/site-packages/psycopg2/init.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use “pip install psycopg2-binary” instead. For details see: http://initd.org/psycopg/docs/install.html#binary-install-from-pypi.
webserver_1 | “”")
dataset_evaluator_1 | 2020-03-05 14:05:37,054 - INFO - Raven is not configured (logging is disabled). Please see the documentation for more information.
hl_extractor_1 | /usr/local/lib/python2.7/site-packages/psycopg2/init.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use “pip install psycopg2-binary” instead. For details see: http://initd.org/psycopg/docs/install.html#binary-install-from-pypi.
hl_extractor_1 | “”")
dataset_evaluator_1 | /usr/local/lib/python2.7/site-packages/psycopg2/init.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use “pip install psycopg2-binary” instead. For details see: http://initd.org/psycopg/docs/install.html#binary-install-from-pypi.
dataset_evaluator_1 | “”")
webserver_1 | * Environment: development
webserver_1 | * Debug mode: on
hl_extractor_1 | High-level extractor daemon starting with 1 threads
webserver_1 | INFO:werkzeug: * Running on http://0.0.0.0:8080/ (Press CTRL+C to quit)
webserver_1 | INFO:werkzeug: * Restarting with stat
webserver_1 | Traceback (most recent call last):
webserver_1 | File “manage.py”, line 318, in
webserver_1 | cli()
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 764, in call
webserver_1 | return self.main(*args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/flask/cli.py”, line 557, in main
webserver_1 | return super(FlaskGroup, self).main(*args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 717, in main
webserver_1 | rv = self.invoke(ctx)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 1137, in invoke
webserver_1 | return _process_result(sub_ctx.command.invoke(sub_ctx))
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 956, in invoke
webserver_1 | return ctx.invoke(self.callback, **ctx.params)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 555, in invoke
webserver_1 | return callback(*args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/decorators.py”, line 17, in new_func
webserver_1 | return f(get_current_context(), *args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/flask/cli.py”, line 412, in decorator
webserver_1 | return __ctx.invoke(f, *args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 555, in invoke
webserver_1 | return callback(*args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/decorators.py”, line 64, in new_func
webserver_1 | return ctx.invoke(f, obj, *args, **kwargs)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/click/core.py”, line 555, in invoke
webserver_1 | return callback(*args, **kwargs)
webserver_1 | File “manage.py”, line 64, in runserver
webserver_1 | extra_files=reload_on_files)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 988, in run_simple
webserver_1 | run_with_reloader(inner, extra_files, reloader_interval, reloader_type)
webserver_1 | File “/usr/local/lib/python2.7/site-packages/werkzeug/_reloader.py”, line 332, in run_with_reloader
webserver_1 | sys.exit(reloader.restart_with_reloader())
webserver_1 | File “/usr/local/lib/python2.7/site-packages/werkzeug/_reloader.py”, line 176, in restart_with_reloader
webserver_1 | exit_code = subprocess.call(args, env=new_environ, close_fds=False)
webserver_1 | File “/usr/local/lib/python2.7/subprocess.py”, line 172, in call
webserver_1 | return Popen(*popenargs, **kwargs).wait()
webserver_1 | File “/usr/local/lib/python2.7/subprocess.py”, line 394, in init
webserver_1 | errread, errwrite)
webserver_1 | File “/usr/local/lib/python2.7/subprocess.py”, line 1047, in _execute_child
webserver_1 | raise child_exception
webserver_1 | OSError: [Errno 8] Exec format error
dataset_evaluator_1 | 2020-03-05 14:05:37,792 - INFO - Starting dataset evaluator…
dataset_evaluator_1 | 2020-03-05 14:05:37,810 - INFO - No pending datasets. Sleeping 30 seconds.
db_1 | 2020-03-05 14:05:37.870 UTC [48] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:37.955 UTC [49] LOG: invalid length of startup packet
acousticbrainz-server_webserver_1 exited with code 1
db_1 | 2020-03-05 14:05:38.878 UTC [50] LOG: invalid length of startup packet
db_1 | 2020-03-05 14:05:38.963 UTC [51] LOG: invalid length of startup packet

running this command gets this “./develop.sh run --rm webserver bash”

Starting acousticbrainz-server_redis_1 … done
Starting acousticbrainz-server_db_1 … done

I’m running windows 10 with docker for desktop and i’ve turned off the windows firewall in case it messes anything up, still the same errors.

Could this maybe run on linux better?

Can you try and follow the same instructions that I posted in the previous comment - changing the values in docker-compose.dev.yml?

As there have been at least 2 people with this issue, I’ll look into finding a windows computer and trying to run it. There seems to be a strange issue going on here.

I run this on linux with no issues, so that will definitely work. It looks like there’s some incompatibility with our setup with Windows Home, which is a bit unfortunate.

1 Like

I looked into this in more detail. It’s a known issue with werkzeug, windows, and docker: https://github.com/pallets/werkzeug/commit/1f532b8ad90c582ca1a756ac472a68c3b552d37c#diff-33c7ca8688be357f6b87529ab9d48402

Either of you could make an update to acousticbrainz to use the most recent version of brainzutils-python. If that doesn’t work, we’ll have to upgrade brainzutils-python to use a newer version of werkzeug and make a new release.

1 Like

@alastairp as you have stated it seems to be a problem with windows.
I tried multiple things to rectify this issue but was not useful. So I tried by installing Linux on my laptop and tried to build and run the site. Although I had some errors while building the site, I could solve them and successfully run the site on my localhost.
@OmarWagih if nothing seems to fix your issue on windows I would suggest you move to Linux and try.