"Preserve Tag" keeps tags but replaces punctuation in the genre tag

Tags: #<Tag:0x00007f58fbe79158> #<Tag:0x00007f58fbe79068> #<Tag:0x00007f58fbe78fa0>

I use Musicbee, which expresses multiple genres like this:
“Genre A; Genre B; Genre C”

I like to manually tag the genres for my music files, so I click “Add to ‘Preserve Tags’ list”. This does preserve the tags; however it replaces the semi-colons with a slash, which Musicbee doesn’t recognise as multiple genres. Essentially I would have to manually retag the genres for every file in my collection, which would take a huge amount of time.

Is there any way I can stop this from happening? I’ve attached a picture so you can see what I mean.

Many thanks :slight_smile:

If this is an MP3 file, you may downgrading the tag version from ID3v2.4 to 2.3, where the latter only supports a single value per tag, so Picard has to fake it with the slash separator. You can change the ID3 version used in the settings.

6 Likes

This solved my problem, thank you so much!