Plugin Problems

musicbrainz
picardplugins
Tags: #<Tag:0x00007f23c2e77d30> #<Tag:0x00007f23c2e77bc8>

#1

Having an issue with plugins. Not necessarily a specific one, all of them. I may be doing something wrong here, but nothing seems to be happening when I install ANY plugin.

One plugin I would like to use is Feat Artists In Titles. I have tried both listed versions of this plugin, and neither are doing their job. Picard is still changing all of the “feat.” to be in the Aritst line which I find annoying for categorization.

Any words of wisdom are welcome. If you need screenshots or bug reports, I can supply them but this seemed pretty straight forward.


#2

What do you mean by “both versions”? How have you installed the plugin (manually or via Options -> Plugins)?

Also make sure the plugin is enabled in options and reload any already loaded albums, since this plugin takes action when an album is loaded from MusicBrainz.


#4

I wasn’t enabling the installed plugins. It’s sorted!


#5

Hope it is ok to hijack this thread.

My plugins tab doesn’t seem to do anything. Tried installing via the install button or via selecting the plugin manually. I can’t tick any boxes and the status never says “Installed”.

I am on Windows 10, fresh installation of Picard v 1.4.2. I don’t have this problem on my Windows 7 machine.

Scripts tab also isn’t working as it is supposed to, but there is another thread about it.

E: 13:19:03 Plugin ‘bpm’ : Traceback (most recent call last):
File “picard\plugin.pyo”, line 299, in load_plugin
File “C:\Program Files (x86)\MusicBrainz Picard\plugins\bpm_init_.py”, line 30, in
ImportError: No module named aubio

D: 13:25:35 Debug mode on
D: 13:25:38 CA Providers order: Cover Art Archive > Amazon > Whitelist > CaaReleaseGroup > Local
D: 13:25:42 Attribute ‘license’ not found for plugin u’featartistsintitles’
D: 13:25:43 WSREQ: Last request to (‘picard.musicbrainz.org’, 443) was 16391 ms ago, starting another one
D: 13:25:43 Received reply for https://picard.musicbrainz.org:443/api/v1/download/?id=featartistsintitles: HTTP 200 (OK) (CACHED)
D: 13:25:44 WSREQ: Last request to (‘picard.musicbrainz.org’, 443) was 1000 ms ago, starting another one
D: 13:25:44 Received reply for https://picard.musicbrainz.org:443/api/v1/download/?id=featartistsintitles: HTTP 200 (OK) (CACHED)
D: 13:25:46 WSREQ: Last request to (‘picard.musicbrainz.org’, 443) was 1934 ms ago, starting another one
D: 13:25:46 Received reply for https://picard.musicbrainz.org:443/api/v1/download/?id=featartistsintitles: HTTP 200 (OK) (CACHED)
D: 13:25:51 WSREQ: Last request to (‘picard.musicbrainz.org’, 443) was 4996 ms ago, starting another one
D: 13:25:51 Received reply for https://picard.musicbrainz.org:443/api/v1/plugins/: HTTP 200 (OK)
D: 13:25:52 Attribute ‘license’ not found for plugin u’featartistsintitles’
D: 13:26:01 Stopping the browser integration
D: 13:26:01 Starting the browser integration (127.0.0.1:8000)


#6

So I have been trying to observe whats going on with plugins. This is what I found.

If I install picard with “including plugins” option, only these plugins will show as installed and are able to be ticked:


Other plugins don’t work at all, as described in above posts.
Also with this option, all the plugins are located in C:\Program Files (x86)\MusicBrainz Picard\plugins (including those that don’t work).

However, there is also a folder C:\Users\UserName\AppData\Roaming\MusicBrainz\Picard\plugins. If I copy plugin file into this folder and it is one of the plugins that is not working by defaultt (as in, those that are NOT stated as “Installed” on the screenshots), it will work. For example, I copied release_type.py in this folder, clicked on it and it works. But if I do the same and copy it to C:\Program Files (x86)\MusicBrainz Picard\plugins, it won’t do anything.

So all in all, it seems like certain plugins will only work when installed to AppData location? Why is this?


#7

I think all “including plugins” does is add a version of the plugin to Program Files for easy installation; the plugins in that folder don’t actually do anything when Picard is running. Instead, as you discovered, they need to be in AppData to do anything, and the “Install” button on the right side of that menu just copies the Program Files versions there. My guess is that’s a remnant of an older structure that didn’t add any plugins to Program Files at all (keeping them in AppData plays a lot more nicely with multiple users on the same computer); the devs later added a mechanism to help people discover plugins rather than sorting through the webpages and manually saving the files, and because the plugins are first downloaded as part of the installation process, it’s just easier to put them with the other installed files.


#8

Those plugins that are “installed” on the screenshot are actually running from Program Files. I can tick them and get them to work, while the AppData folder is empty. If I copy lastfm plugin to AppData, Picard goes totally nonresponsive, it won’t even start. I am not sure why this is, but I guess for now the workaround is to manually copy the plugins to AppData folder - exlucing the ones that are already “installed” and working in Program Files.


#9

I got the same issue…
any conclusion how to make it work?