Please test new Picard Windows builds

development
prerelease
testing
Tags: #<Tag:0x00007fe3d12631c8> #<Tag:0x00007fe3d1263060> #<Tag:0x00007fe3d1262ef8>

#1

We had some changes to how Picard is being built for Windows. The goal is to allow Picard to be built with the latest versions of libraries we use. Since I can only test on a limited set of Windows systems myself, I would appreciate if some users could test the current builds.

If you want to help ensure that the next Picard release will run on as many Windows systems as possible, please download the development build installer picard-setup-2.0.5.dev1.exe

Installing this release will replace your existing installation, but you can always reinstall Picard 2.0.4 again after testing.

The usual disclaimer applies: While the current Picard development release usually is quite stable, this is still a development build and unexpected issues can happen. Please make a backup of your configuration and of the music files you are processing with this build.

One ser visible Windows related change in this build is that it will add customized tiles to the Windows 10 start menu. Feedback on this is also highly welcomed. There has been some discussion about the background color. If you have some sense for design and an idea how to improve this please let us know. Here is what it does look like now:

screenshot-2018-10-05-08-33-34

Some more screenshots can be found in the pull request.

If you are curious what else is new in this build take a look at the tickets for Picard 2.1


#2

The link to the “tickets for Picard 2.1” needs a login. Is there a publicly view-able version?

What kind of checks do you need done? Due to the nature of my job I have a number of PCs knocking around I can run installations on. Including a Vista box sitting on the floor behind me that was due to be scrapped.

One initial bit of feedback I’d give is on the Win10 tile. As someone who adjusts the colouring of his own Win10 menu I’d personally prefer the background of the tile to be invisible so I can keep my own start menu colouring. Though that purple is quite nice if it has to be coloured.


#3

Sorry, updated a link to a one that should work. Don’t quite understand why the other view is not public, it’s definitely nicer.

My main concern really is that it must start. But testing some functiinality like scanning, lookup and open in browser would be good as well.

The problem with not defining a color is that Windows then uses that blue by default, which does not really work well with the logo colors.


#4

A post was split to a new topic: New plugin user interface in Picard development version


#5

When you say “uses blue by default” - have you set the Start Menu to be coloured? The colours chosen are pretty good though.

I’m stuffing this on a memory stick and trying on a few computers for you. I assume Vista is as old as you go now.


#6

It seems to be running without issues for me on Windows x64 until now.
The ‘solo’ attribute seems to be fixed too, and is now again tied to the instrument, so that’s nice.


#7

Feedback from installing on various Windows PCs. (This post will keep getting up dated with other findings as I run on other PCs)

Win10 Pro (x86) PC first.

Missing icon at install time
During install I ticked “Start menu”, “Desktop” and “Taskbar” icons. Only the first two appeared - no icon was added to the taskbar.

Do I assume you are not automatically pinning a Tile to the Start Menu? Just adding to the normal A to Z list of applications.

Start Menu Tile
Funnily enough, when I pinned up the Tile to the Start Menu it fitted this PC almost perfectly as it is a very very similar shard of violet. :smiley: Still think that transparent would be better as it allows more choice for the user.

BUG IN THE INSTALLER
Found my first show stopper of an issue. Why does the installer not warn that this is a 64-bit app? I happened to pick a 32-bit Win10 PC to test on. The installer ran right through to the end, and only when I tried to run the application did I get told it was not compatible.

The “Is this a 64-bit PC?” test should really happen in the installer.

(I think I remember something saying there will be no 32-bit release. So this Win10 PC is now abandoned from this test)

Test of uninstaller
This passed with flying colours. No traces left after uninstallation.

-=-=-=-

Vista Home Premium (x64)

Ahhh… the ever lovely Windows Vista. Everyone’s favourite OS…

Missing icon at install time
This time all three did appear. The Quicklaunch\taskbar icons is present this time.

Launch Application fails - Error Loading Python
Message box appears:
Error loading Python DLL: C:\Program Files\MusicBrainz\Picard\python37.dll
LoadLibrary: A dynamic link library (DLL) initialization routine has failed

Should the Picard installer have installed the relevant Python libraries? I remember this coming up a few months back but the implication there was this should work on Vista x64. (Python 3.7 claims to still work on Vista)

Rebooting made no difference. Let me know what else to check here.

(More tests to follow…)


#8

No, that “Task Bar” does not even exist on Windows 10 anymore AFAIK. It’s that area which I think was also called “Quick Launch” on the very left of the task bar, where some fixed icons where placed. With changing the taskbar to a more dock like behavior this no longer exists. I think we should probably remove this from the installer. I added PICARD-1370

I added PICARD-1371

This is exactly the kind of issue I am looking for :slight_smile: Of course all required libraries should be installed, but this indicates an incompatibility of this DLL with your system.

To narrow this down can you please try the following:

  1. Does current Picard 2.0.4 run on this system?
  2. Does the Python 3.6 version from https://ci.appveyor.com/project/MetaBrainz/picard/builds/19319509/job/letviba4kevtbdp1/artifacts work?
  3. Does the Python 3.5 version from https://ci.appveyor.com/project/MetaBrainz/picard/builds/19319509/job/sc6gu899gfchgq0u work?

#9

Quick reply to that… no Picard has ever been used on this computer before. Totally fresh install.

1\ I am kinda guessing that the answer to 1 will be “No” as this was brought up in August. I’ll still get hold of the current installer and confirm.

2\ and 3\ You are being way too cryptic. I do not work on the Picard project so don’t know what that page is saying. Give me a better hint of what is needed. How would I swap Picard to use older versions of Python?

The Python site does imply that v3.7 should work on Vista x64. Is there a config file I can tweak to make the change?

And yes - I was expecting these odd machines to cause problems. It is why I picked them. :smiley: No point in doing simple testing. It is the Bastard Testing that brings out the useful stuff. :wink:

Update: I am guessing that by running v2.0.4 it tells us that question 2 and Python v3.6 will also fail.

I have again tried to make sens of the appveyor.com link to a Python 3.5 version but I can’t see where the exe is. Just seems to be the output of a logfile to me.


#10

More on the VISTA x63 test

Uninstall does not remove all icons
The DESKTOP and START MENU icons are left behind. The Quicklink icon is deleted correctly.

Ah… looking again it is just the Start Menu icon that is left behind. If I refresh the desktop with < f5 > the icon goes away. (Yeah - ignore this one. Likely just the old senile PC I am testing with)

Uninstall does not ask to remove settings
May be worth noting that on Win10 I was asked about removing my settings. I was not asked this on Vista. Could this be why the icons got left behind?

All other application files correctly removed. nothing in %PROGRAMFILES% and nothing in %APPDATA% but I assume that is also due to not starting the app.

Install test for v2.0.4
This behaves exactly the same as v2.0.5. Will not start the app and gives similar error as reported above. Only this time it is complaining about the Python36.dll

In both cases I check that the Python36.dll is sitting in the correct folder next to picard.exe


#11

Sorry, I had assumed these links would open the correct tab. If you click on “Artifacts” there should be a link to an installer download. The filename is always the same, but they are built with different Python versions.

Just quickly replying from mobile right now, so I cannot check in detail. But if you need more details I can check this later.


#12

Got it. Will just pick the v3.5 version as the failed v2.0.4 install I assume means we covered the Python 3.6 test.


#13

And same result. Same error message but now it complains about Python35.

I am about to disappear for an hour or so. But this Vista PC will be fully available to you in any way you like. From me uploading log files through to you having a direct remote connection to it. It is an ex-customer PC about to be wiped so it can hang around for this debugging.


#14

Thanks a lot for the offer, but I think we should take this as the information “doesn’t run on Vista”. Given that Vista is not even listed among the supported configurations for Qt 5.11, is not supported by MS anymore, and the fact that Vista itself, especially in the 64bit version, wasn’t tremendously popular anyway I really don’t want to invest too much of my (or your) time debugging this.

I am currently testing with a fresh install of Win 7, let’s see how this goes :smiley:


#15

I agree with you. So few people will be using Vista now. I’ve migrated a few people onto new PCs in the last month after Firefox abandoned the OS.

Please can the “supported OS” list be updated. If someone is running Vista then should be pointed at Picard v1.4.2 as a solution.

Later in the day I’ll find some more victims to install Picard onto. I have a very messy Win7 here that will probably be next.


#16

I think that implies having a “Supported OS” list first :smiley:


#17

Some results from my own testing on Windows 7: The current Picard 2.0.4 and the development version behave the same. They both run on Windows 7, but on a fresh install I first had to install Service Pack 1 and some following “important” updates until it would start. So probably we should just recommend Windows 7 + Service Pack 2 as the minimum to be on the save side.


#18

Agree. I’ll refer you to the Microsoft Supported list. https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet

They don’t support unpatched Win7 either, but there is no SP2. Win7 SP1 ran out of official mainstream support at the end of 2015. It will be abandoned fully at the end of 2020.

I would suggest write “A fully patched Windows 7 SP1 required”. Then leave it to the user if they want to experiment with missing patches.


#19

Dear ALL,

  • “updating” latest Picart to 2.0.5.dev1 version on W10PRO/64 - Intel Core 2 / 4GB, install himself to Program Files(x86). So, is it the DEV version 64 bit ?
  • Daily functions, Load, Cluster, LookUp, Scan, Save, Remove works well - as in latest version
  • no plugin activated, just changed litlebit the naming convection …
  • still not clear how plugins fuctioning . eg. when they start / run ?
    Really nice app :slight_smile:
    I’m using it for clean up and organize my music data base for use with volumio …

Regards,