Picard works incorrectly with Cyrillic and symbols like ó, ż etc

With Cyrillic, folders and file names look like ___ ___ __. With Polish symbols like ż, ź etc. it just replaces it with with wrong symbols. I do have Cyrillic decode plugin installed. Thanks!

Is this only in file names or also in the tags? See if you have “Replace non-ASCII characters” enable in Options > File naming > Compatibility (or just Options > File naming in Picard before 2.9). This option should be disabled if you want to save non-ASCII characters.

On a side note, you usually don’t want to use the decode Cyrillic plugin unless you have files with wrongly encoded Cyrillic characters. But as this plugin does not do anything automatic (it is a manual action triggered via the context menu on a cluster) it should not matter in this case.


It recognizes fonts in tags very well.

Polish, Russian, Chinese… :wink:

I didn’t check the filenames.

Screenshot of MP3Tag, sorted by Artist.

Only file names, tags are fine. (Polish too, apparently).

After disabling that plugin and disabling “Replace non-ASCII characters” in settings it started to work just fine. Thanks!