Picard unresponsive at startup


#1

Hello,

So every time I try to launch MusiBrainz picard, the program is stuck and unresponsive for what feels like 10-15 mins. I can’t. I went through options, tried reinstalled (including clean install), making sure i uee the newest version etc.

What I noticed though is, there is the little green arrow in bottom right corner that says “2” - this is while its unresponsive. Once the program becomes responsive again, the arrow becomes grey.

ss: http://imgur.com/a/11qRj

Whats this arrow and why does it take SO long?


#2

You don’t give enough information for us to help you:


#3

Picard will check for a newer version on start up so perhaps it is trying to do that and it is failing.
You could try a daily build and see if that has the same problem.

There could also be a plugin causing problems, try and disable these.


#4
  • Windows 10
  • W: 12:47:35 Module ‘featartistsintitles’ conflict: unregistering previously loaded ‘Feat. Artists in Titles’ version 0.2 from 'C:\Program Files (x86)\MusicBrainz Picard\plugins\featartistsintitles.py
    W: 12:47:35 Module ‘release_type’ conflict: unregistering previously loaded ‘Release Type’ version 1.2 from ‘C:\Program Files (x86)\MusicBrainz Picard\plugins\release_type.py’
  • MusicBrainz Picard v 1.4.0dev5 (previously I used latest stable build though)

#5

Hardly the full debug log, it would be nice if you could enable debug mode (-d command line option or through Help > View logs > Check Debug Mode).


#6

I tried the suggested method, but ran into couple of issues.

I can only enable debug mode after I start the program (… and after 30mins wait until the program becomes responsive). When enabled, it is either empty or contain 2 lines pasted in my earlier post. Obviously, when I start using the program, it fills up, but I don’t have a problem with functionality at all, so I am not sure if it would be relevant?

When I try running the shortcut with -d parameter, the program simply won’t start at all.

I tried uninstalling MusicBrainz Picard including deleting all plugins from my hdds and cleaning the registers. Fresh install surprisigly worked flawlessly first 2 times, then after that the unresponsive startup is back. All I did is go to options and changed the language (I also seemed to be logged in by default).


#7

That’s really a long time, I have no good explanation what could cause this. Do you open Picard normally or with some folder to load? What plugins do you have enabled, does disabling plugins improve the situation? Or maybe you have some network drives which are not accessable and Picard’s file browser gets stuck somehow?

That should actually work and has the best chance of giving us some clue in what is happening. How did you set the parameter in the shortcut?


#8

From what I understand, normally. However I disabled “Move files when saved” option (I had my music folder path specified there) and closed the app. Started again and it is instant!
Could this be an early sign that my hdd is dying? I’ll do a scan tonight to see if it’s got any bad sectors.

Disabled all plugins for now.

EDIT:So it only lasted for 1 attempt, now its unresponsive again

“C:\Program Files (x86)\MusicBrainz Picard\picard.exe” -d
Right clicking on the desktop shortcut - Properties - Target. It works on my work computer.
.


#9

I have a similar problem. I have gone back to older versions but have the same unresponsive behaviour. My debug log shows:

D: 21:44:10 Debug mode on

D: 21:44:10 Starting Picard from 'C:\Program Files (x86)\MusicBrainz Picard\library.zip\picard\tagger.pyo’

D: 21:44:10 Platform: Windows-8-6.2.9200 CPython 2.7.6

D: 21:44:10 Versions: Picard 1.4.2, PyQt 4.10.3, Qt 4.8.5, Mutagen 1.36, Discid discid 1.1.1, libdiscid 0.6.1

D: 21:44:10 Configuration file path: u’C:/Users/thebi/AppData/Roaming/MusicBrainz/Picard.ini’

D: 21:44:10 User directory: 'C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard’

D: 21:44:10 Using locale 'en_GB’

D: 21:44:10 Loading gettext translation, localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 21:44:10 Loading gettext translation (picard-countries), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 21:44:10 IOError(2, ‘No translation file found for domain’)

D: 21:44:10 _ = <function at 0x0310C0B0>

D: 21:44:10 N = <function at 0x025267F0>_

_D: 21:44:10 ungettext = <function ungettext at 0x0310C0F0>

_D: 21:44:10 ugettext_countries = <function ugettext_countries at 0x0310C130>

_D: 21:44:10 ugettext_attributes = <function ugettext_attributes at 0x0310C170>

D: 21:44:10 NetworkDiskCache dir: C:/Users/thebi/AppData/Local/MusicBrainz/Picard/cache/picard/

D: 21:44:10 NetworkDiskCache size: 44960359 / 104857600

I: 21:44:10 Plugin directory ‘C:\Program Files (x86)\MusicBrainz Picard\plugins’ doesn’t exist

D: 21:44:10 Looking for plugins in directory ‘C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard\plugins’, 0 names found

D: 21:44:10 Starting the browser integration (127.0.0.1:8000)

D: 21:44:10 WSREQ: First request to (‘picard.musicbrainz.org’, 443)

D: 21:44:11 WSREQ: First request to (u’musicbrainz.org’, 443)

_D: 21:44:34 Received reply for https://musicbrainz.org:443/ws/2/collection: HTTP 200 (OK) _

D: 21:44:34 Received reply for https://picard.musicbrainz.org:443/api/v1/plugins/: HTTP 200 (OK)


#10

Following from the error above, I managed to change the language from EN-GB to EN, and the log shows as below. Unfortunately there is no improvement in the responsiveness.

D: 22:07:28 Debug mode on

D: 22:07:28 Starting Picard from 'C:\Program Files (x86)\MusicBrainz Picard\library.zip\picard\tagger.pyo’

D: 22:07:28 Platform: Windows-8-6.2.9200 CPython 2.7.6

D: 22:07:28 Versions: Picard 1.4.2, PyQt 4.10.3, Qt 4.8.5, Mutagen 1.36, Discid discid 1.1.1, libdiscid 0.6.1

D: 22:07:28 Configuration file path: u’C:/Users/thebi/AppData/Roaming/MusicBrainz/Picard.ini’

D: 22:07:28 User directory: 'C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard’

D: 22:07:28 Using locale 'en_GB’

D: 22:07:28 Loading gettext translation, localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:07:28 Loading gettext translation (picard-countries), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:07:28 IOError(2, ‘No translation file found for domain’)

D: 22:07:28 _ = <function at 0x0318C0B0>

D: 22:07:28 N = <function at 0x027067F0>_

_D: 22:07:28 ungettext = <function ungettext at 0x0318C0F0>

_D: 22:07:28 ugettext_countries = <function ugettext_countries at 0x0318C130>

_D: 22:07:28 ugettext_attributes = <function ugettext_attributes at 0x0318C170>

D: 22:07:28 NetworkDiskCache dir: C:/Users/thebi/AppData/Local/MusicBrainz/Picard/cache/picard/

D: 22:07:28 NetworkDiskCache size: 44960359 / 104857600

I: 22:07:28 Plugin directory ‘C:\Program Files (x86)\MusicBrainz Picard\plugins’ doesn’t exist

D: 22:07:28 Looking for plugins in directory ‘C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard\plugins’, 0 names found

D: 22:07:28 Starting the browser integration (127.0.0.1:8000)

D: 22:07:28 WSREQ: First request to (‘picard.musicbrainz.org’, 443)

D: 22:07:30 WSREQ: First request to (u’musicbrainz.org’, 443)

_D: 22:07:52 Received reply for https://musicbrainz.org:443/ws/2/collection: HTTP 200 (OK) _

D: 22:07:52 Received reply for https://picard.musicbrainz.org:443/api/v1/plugins/: HTTP 200 (OK)


#11

Went back to version 1.3.1. This works fine

D: 22:19:15 Debug mode on

D: 22:19:15 Starting Picard from 'C:\Program Files (x86)\MusicBrainz Picard\library.zip\picard\tagger.pyo’

D: 22:19:15 Platform: Windows-8-6.2.9200 CPython 2.7.9

D: 22:19:15 Versions: Picard 1.3.1, PyQt 4.11.2, Mutagen 1.25.1, Discid discid 1.1.0, libdiscid 0.6.1

D: 22:19:15 Configuration registry path: \HKEY_CURRENT_USER\Software\MusicBrainz\Picard

D: 22:19:15 User directory: C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard

D: 22:19:15 Using locale 'English_United Kingdom.1252’

D: 22:19:15 Loading gettext translation, localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:19:15 Loading gettext translation (picard-countries), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:19:15 Loading gettext translation (picard-attributes), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:19:15 _ = <bound method GNUTranslations.ugettext of <gettext.GNUTranslations instance at 0x0300F490>>

D: 22:19:15 N = <function at 0x0259FA70>_

D: 22:19:15 ungettext = <bound method GNUTranslations.ungettext of <gettext.GNUTranslations instance at 0x0300F490>>

D: 22:19:15 ugettext_countries = <bound method GNUTranslations.ugettext of <gettext.GNUTranslations instance at 0x03017E40>>

D: 22:19:15 ugettext_attributes = <bound method GNUTranslations.ugettext of <gettext.GNUTranslations instance at 0x030260A8>>

D: 22:19:15 NetworkDiskCache dir: C:/Users/thebi/AppData/Local/MusicBrainz/Picard/cache/picard/

D: 22:19:15 NetworkDiskCache size: 44960359 / 104857600

W: 22:19:15 Plugin directory ‘C:\Program Files (x86)\MusicBrainz Picard\plugins’ doesn’t exist

D: 22:19:15 Looking for plugins in directory ‘C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard\plugins’, 0 names found

D: 22:19:15 Starting the browser integration (127.0.0.1:8000)


#12

Version 1.3.2 works well

D: 22:40:58 Debug mode on

D: 22:40:58 Starting Picard from 'C:\Program Files (x86)\MusicBrainz Picard\library.zip\picard\tagger.pyo’

D: 22:40:58 Platform: Windows-8-6.2.9200 CPython 2.7.6

D: 22:40:58 Versions: Picard 1.3.2, PyQt 4.10.3, Mutagen 1.25, Discid discid 1.1.0, libdiscid 0.6.1

D: 22:40:58 Configuration registry path: \HKEY_CURRENT_USER\Software\MusicBrainz\Picard

D: 22:40:58 User directory: C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard

D: 22:40:58 Using locale 'English_United Kingdom.1252’

D: 22:40:58 Loading gettext translation, localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:40:58 Loading gettext translation (picard-countries), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:40:58 Loading gettext translation (picard-attributes), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:40:58 _ = <bound method GNUTranslations.ugettext of <gettext.GNUTranslations instance at 0x02F47FA8>>

D: 22:40:58 N = <function at 0x026D9970>_

D: 22:40:58 ungettext = <bound method GNUTranslations.ungettext of <gettext.GNUTranslations instance at 0x02F47FA8>>

D: 22:40:58 ugettext_countries = <bound method GNUTranslations.ugettext of <gettext.GNUTranslations instance at 0x02F54968>>

D: 22:40:58 ugettext_attributes = <bound method GNUTranslations.ugettext of <gettext.GNUTranslations instance at 0x02F54B98>>

D: 22:40:58 NetworkDiskCache dir: C:/Users/thebi/AppData/Local/MusicBrainz/Picard/cache/picard/

D: 22:40:58 NetworkDiskCache size: 46609165 / 104857600

D: 22:40:58 Looking for plugins in directory ‘C:\Program Files (x86)\MusicBrainz Picard\plugins’, 17 names found

D: 22:40:58 Loading plugin u’Add Cluster As Release’ version 0.5, compatible with API: 1.0

D: 22:40:58 Loading plugin u’Album Artist Website’ version 0.3, compatible with API: 0.15, 0.15.1, 0.16, 1.0, 1.1, 1.2, 1.3

D: 22:40:58 Loading plugin ‘Classic Disc Numbers’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin u’Generate Cuesheet’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin ‘Disc Numbers’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin ‘Feat. Artists Removed’ version 0.2, compatible with API: 0.15, 0.16

D: 22:40:58 Loading plugin ‘Feat. Artists in Titles’ version 0.2, compatible with API: 0.15, 0.16

D: 22:40:58 Loading plugin u’Last.fm’ version 0.4, compatible with API: 0.15

D: 22:40:58 Loading plugin u’Last.fm.Plus’ version 0.14, compatible with API: 0.15

D: 22:40:58 Loading plugin u’No release’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin ‘Release Type’ version 1.2, compatible with API: 0.15

D: 22:40:58 Loading plugin u’ReplayGain’ version 0.1, compatible with API: 0.15, 0.16

D: 22:40:58 Loading plugin u’Sort Multi-Value Tags’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin u’Standardise Performers’ version 0.2, compatible with API: 0.15, 0.15.1, 0.16, 1.0, 1.1, 1.2, 1.3

D: 22:40:58 Loading plugin ‘Title Case’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin u’Copy Cluster to Clipboard’ version 0.1, compatible with API: 0.15

D: 22:40:58 Loading plugin u’View script variables’ version 0.5, compatible with API: 1.0

D: 22:40:58 Looking for plugins in directory ‘C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard\plugins’, 0 names found

D: 22:40:58 Starting the browser integration (127.0.0.1:8000)

D: 22:40:58 Last request to (u’musicbrainz.org’, 80) was 1000 ms ago, starting another one

D: 22:40:58 GET https://musicbrainz.org/ws/2/collection

_D: 22:41:01 Received reply for https://musicbrainz.org/ws/2/collection: HTTP 200 (OK) _

D: 22:42:20 Stopping the browser integration

D: 22:42:20 Starting the browser integration (127.0.0.1:8000)


#13

Version 1.4 and upward seems all to be broken:

D: 22:46:41 Debug mode on

D: 22:46:41 Starting Picard from 'C:\Program Files (x86)\MusicBrainz Picard\library.zip\picard\tagger.pyo’

D: 22:46:41 Platform: Windows-8-6.2.9200 CPython 2.7.6

D: 22:46:41 Versions: Picard 1.4 (win_20170214120233), PyQt 4.10.3, Qt 4.8.5, Mutagen 1.36, Discid discid 1.1.1, libdiscid 0.6.1

D: 22:46:41 Configuration file path: u’C:/Users/thebi/AppData/Roaming/MusicBrainz/Picard.ini’

D: 22:46:41 User directory: 'C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard’

D: 22:46:41 Using locale 'en_GB’

D: 22:46:41 Loading gettext translation, localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:46:41 Loading gettext translation (picard-countries), localedir='C:\Program Files (x86)\MusicBrainz Picard\locale’

D: 22:46:41 IOError(2, ‘No translation file found for domain’)

D: 22:46:41 _ = <function at 0x031A2DB0>

D: 22:46:41 N = <function at 0x027596F0>_

_D: 22:46:41 ungettext = <function ungettext at 0x031A2DF0>

_D: 22:46:41 ugettext_countries = <function ugettext_countries at 0x031A2E30>

_D: 22:46:41 ugettext_attributes = <function ugettext_attributes at 0x031A2E70>

D: 22:46:41 NetworkDiskCache dir: C:/Users/thebi/AppData/Local/MusicBrainz/Picard/cache/picard/

D: 22:46:41 NetworkDiskCache size: 46609165 / 104857600

I: 22:46:41 Plugin directory ‘C:\Program Files (x86)\MusicBrainz Picard\plugins’ doesn’t exist

D: 22:46:41 Looking for plugins in directory ‘C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard\plugins’, 33 names found

D: 22:46:41 Loading plugin u’Abbreviate artist-sort’ version 0.2, compatible with API: 1.0

D: 22:46:41 Loading plugin u’Abbreviate Artist-Sort v2’ version 1.0, compatible with API: 1.4

D: 22:46:41 Loading plugin u’AcousticBrainz Mood-Genre’ version 0.0, compatible with API: 0.15

D: 22:46:41 Loading plugin u’AcousticBrainz Tonal-Rhythm’ version 0.1, compatible with API: 1.4

D: 22:46:41 Loading plugin u’Add Cluster As Release’ version 0.7.1, compatible with API: 1.0

D: 22:46:41 Loading plugin u’Album Artist Website’ version 0.6, compatible with API: 1.4

E: 22:46:41 Plugin ‘bpm’ : Traceback (most recent call last):
_ File “picard\plugin.pyo”, line 301, in load_plugin_
_ File “C:\Users\thebi\AppData\Roaming\MusicBrainz\Picard\plugins\bpm.zip\bpm_init_.py”, line 30, in _
ImportError: No module named aubio

D: 22:46:41 Loading plugin ‘Classic Disc Numbers’ version 0.1, compatible with API: 0.15

D: 22:46:41 Loading plugin u’Generate Cuesheet’ version 0.2, compatible with API: 0.15

D: 22:46:41 Loading plugin u’Decode Cyrillic’ version 1.0, compatible with API: 1.0

D: 22:46:41 Loading plugin ‘Disc Numbers’ version 0.1, compatible with API: 0.15

D: 22:46:41 Loading plugin ‘Feat. Artists Removed’ version 0.3, compatible with API: 0.15, 0.16

D: 22:46:41 Loading plugin ‘Feat. Artists in Titles’ version 0.3, compatible with API: 0.15, 0.16

D: 22:46:41 Loading plugin ‘Keep tags’ version 1.1, compatible with API: 0.15, 0.15.1, 0.16, 1.0, 1.1, 1.2, 1.3

D: 22:46:41 Loading plugin u’Load as non-album track’ version 0.1, compatible with API: 1.4

D: 22:46:41 Loading plugin u’No release’ version 0.1, compatible with API: 0.15

D: 22:46:41 Loading plugin ‘Non-ASCII Equivalents’ version 0.1, compatible with API: 0.15

D: 22:46:41 Loading plugin ‘Padded disc and tracknumbers’ version 1.0, compatible with API: 0.15, 0.15.1, 0.16, 1.0, 1.1, 1.2, 1.3

D: 22:46:41 Loading plugin u’Paper CD case’ version 0.1, compatible with API: 1.3, 1.4

D: 22:46:41 Loading plugin u’Generate M3U playlist’ version 0.3, compatible with API: 1.0, 1.1, 1.2, 1.3

D: 22:46:41 Loading plugin ‘Release Type’ version 1.3, compatible with API: 0.15

D: 22:46:41 Loading plugin u’Remove Perfect Albums’ version 0.2, compatible with API: 0.15

D: 22:46:41 Loading plugin u’Re-order sides of a release’ version 0.1, compatible with API: 1.3

D: 22:46:41 Loading plugin u’Save and rewrite header’ version 0.2, compatible with API: 0.15

D: 22:46:41 Loading plugin ‘Smart Title Case’ version 0.1, compatible with API: 1.4

D: 22:46:41 Loading plugin u’Sort Multi-Value Tags’ version 0.2, compatible with API: 0.15

D: 22:46:41 Loading plugin ‘Soundtrack’ version 0.1, compatible with API: 1.0

D: 22:46:41 Loading plugin ‘Standardise Feat.’ version 0.1, compatible with API: 1.4

D: 22:46:41 Loading plugin u’Standardise Performers’ version 0.2, compatible with API: 0.15, 0.15.1, 0.16, 1.0, 1.1, 1.2, 1.3

D: 22:46:41 Loading plugin ‘Tango.info Adapter’ version 0.1.5, compatible with API: 1.3, 1.4

D: 22:46:41 Loading plugin ‘Title Case’ version 0.1, compatible with API: 0.15

D: 22:46:41 Loading plugin u’Copy Cluster to Clipboard’ version 0.1, compatible with API: 0.15

D: 22:46:41 Loading plugin ‘wikidata-genre’ version 0.2, compatible with API: 0.15

D: 22:46:41 Starting the browser integration (127.0.0.1:8000)

D: 22:46:41 WSREQ: First request to (‘picard.musicbrainz.org’, 443)

D: 22:46:42 WSREQ: First request to (u’musicbrainz.org’, 443)


#14

What appeared to cause my problem was actually a faulty cd-rom drive. I’ve been having problems with it for a while, so I tried unplugging it and run picard - it suddenly worked smooth, even the new version.

Not sure if this is the same issue for you though.


#15

I don’t have any external drives, so that would not be an issue. Did yours become unresponsive when accessing the drive, or was it unresponsive from startup? I wonder if it is not perhaps looking for a CD-ROM, which doesn’t exist?


#16

It was unresponsive right from the startup. CD-ROM was just idle, I never used it for anything.
It seems like picard does some sort of drive check upon its launch, so maybe it would be worth it to scan your internal drives for any errors or such.