Picard tags Compilation not Albums or Single [sliders don't seem to do anything]

Tags: #<Tag:0x00007f0509307248>


I’ve got a Now That’s What I Call Music album and I want the songs to be tagged individually with their own albums.
I tried Newbie here. Picard seems to be prefering tags other than the original release but the sliders don’t seem to help at all. I’ve faced similar problems with other tracks.

The green TAGGER button on the lookup page does nothing when clicked. When I open it in a new tab, Chrome shows
This site can’t be reached refused to connect.

Pls don’t redirect me to the above mentioned thread.

Original album?

How do you do the lookup. In this case you should not use cluster and then lookup, but rather just lookup or maybe scan. Make sure to have the sliders set accordingly as to the thread you linked. Cluster will result in Picard trying to find a single release that matches all the tracks.

As to how to load releases into Picard the thread below has some alternative suggestions if the tagger button does not work:

Regarding the tagger button not working maybe look at

Also the tagger button has AFAIK issues with HTTPs, not sure how the state is here and if there anybody had an idea how to solve it


This is expected behaviour as far as I can tell.

As well as what outsidecontext said, ‘Lookup’ is using the existing tags to match your tracks. If they are all currently tagged with ‘Now That’s What I Call Music’ as the album, MB is going to look for that album. The sliders help with edge cases but in this case the data is pretty clearly (and correctly) telling Picard what album they’re from.

‘Scan’ on the other hand will ignore all existing tags, and then you’ve just got to cross your fingers and hope someone’s submitted the AcoustID for each of those tracks, and linked them to the correct album. Scan does its best but it’s not a mind reader so you’ll probably have to do a bit of manual choosing editions/finding albums.

Or you can delete the current ‘album’ tags and use Lookup, might give better results - let us know what works for you please!

If you need a workaround on the green tagger button not working, you can paste the release url into the search bar in Picard. That should load the release.
Maybe we’re still having some issues from the big server move just a few days ago, but I really don’t know.


Sorry guys, lookup does a better job than scan.
I had been using Picard for just a few weeks, I wasn’t sure about lookup’s use, so I kept on using scan.

TY for the replies.
MusicBrainz has a really good community.