Picard not writing TDOR for original year

Tags: #<Tag:0x00007fe30e72ab20> #<Tag:0x00007fe30e72aa30> #<Tag:0x00007fe30e72a918>

For storing the ‘original date’, ID3 v2.4 has the tag frame TDOR.
But it looks like Picard is not writing that, but instead it writes TXXX/origyear

Why is that, and more importantly, is there a setting or a script to correct that?

According to the documentation, Picard does write the original release date to TDOR (at least if you use version 2.4, for 2.3 it writes to TORY). But according to that documentation, it doesn’t even write the original year to id3 tags, so it may just be wrong or a bug.

You could try this script: $copy(_id3:TXXX:origyear,TDOR)

Thanks for the fast support mfmeulenbelt

I am using 2.4, and Picard is not writing TDOR.
Thanks for the script. Right now it is breaking some other date script I am running, but I should be able to figure that out.

Is $copy the only way to get such a result? There is no setting (perhaps in a .ini or config file) to have Picard writing TDOR in the first place?

After further investigation, I found out that after disabling all plugins and scripts, Picard does write both TDOR and TXXX/origyear.
So it is some plugin or script that breaks TDOR for me.

An odd observation is that for an album I am currently testing this with, with no scripts running, Picard writes ‘YYYY’ for TXXX/origyear, but ‘YYYY-MM’ for TDOR.
So I’ve got more investigating and patchwork coming up…

Picard provides two tags: originaldate and originalyear.

originalyear is just the year part of originaldate. It depends on that tagging format what gets written where. For ID3 it stores originaldate to TDOR (since this supports YYYY-MM) format.

Actually IMHO it should not store originalyear to ID3 at all. Originally Picard didn’t do this, but at some point the default behavior changed to write all otherwise unknown tags to TXXX: frames. This is a side effect of this.

If it bothers you under the originalyear variable:


Clear. Thank you outsidecontext

1 Like