Picard keeps nesting folders deeper and deeper when saving albums


Pretty much as the title says, every time I save an album it nests deeper and deeper, like this.

Is there an easy way to undo this? This is sort of being a pain.



Under Options → Options → File Naming, do you have “Move files when saving” checked? And if so, what is the “Destination directory”?

Why do my file names repeat multiple times?

Yes, I enabled that on purpose to reorganize my personal library.
Directory is a mere dot, that might explain it.
Yeah, manually setting it to the music dir fixed it.

Seems odd that this is the default. Like, I can understand, but I can’t imagine being the first running into this one nor the last. Perhaps add a notification box when checking move files?


Well, there is no good default. But I would have thought the “.” to refer to the directory where picard was started from, not the directory where the music file currently resides.

If the default is really useless, maybe picard should make the field empty by default and disallow checking the “rename” option unless you enter a directory.