Picard freezes upon launch in macOS Big Sur beta

Tags: #<Tag:0x00007f7cf7f880d8> #<Tag:0x00007f7cf7f8ff90>

Yes, I know it’s a beta :wink: but thought you guys might like to know.

Using your latest beta 2.04b2 and latest Big Sur (beta 4).

1 Like

Can you run picard with the --debug command line argument and send the results.

"/Applications/MusicBrainz Picard/Contents/MacOS/picard-run" --debug

Sure

MacBook-Pro:~ jhwalker$ /Applications/MusicBrainz\ Picard.app/Contents/MacOS/picard-run --debug

D: 21:49:03,147 tagger.init:225: Starting Picard from ‘/Applications/MusicBrainz Picard.app/Contents/MacOS/picard/tagger.pyc’

D: 21:49:03,148 tagger.init:227: Platform: Darwin-20.0.0-x86_64-i386-64bit CPython 3.7.6

D: 21:49:03,148 tagger.init:228: Versions: Picard 2.4.0b2, Python 3.7.6, PyQt 5.13.2, Qt 5.13.2, Mutagen 1.44.0, Discid discid 1.2.0, libdiscid 0.6.2, astrcmp C, SSL Secure Transport, macOS 10.16

D: 21:49:03,148 tagger.init:229: Configuration file path: ‘/Users/jhwalker/.config/MusicBrainz/Picard.ini’

D: 21:49:03,148 tagger.init:231: User directory: ‘/Users/jhwalker/Library/Preferences/MusicBrainz/Picard’

D: 21:49:03,232 i18n.setup_gettext:83: Using locale ‘en_US’

D: 21:49:03,233 i18n.setup_gettext:85: Loading gettext translation, localedir=’/Applications/MusicBrainz Picard.app/Contents/MacOS/locale’

D: 21:49:03,234 i18n.setup_gettext:87: Loading gettext translation (picard-countries), localedir=’/Applications/MusicBrainz Picard.app/Contents/MacOS/locale’

D: 21:49:03,234 i18n.setup_gettext:92: [Errno 2] No translation file found for domain: ‘picard-countries’

D: 21:49:03,234 i18n.setup_gettext:108: _ = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x7ffbb6e64450>>

D: 21:49:03,234 i18n.setup_gettext:109: N_ = <function at 0x7ffbb6632290>

D: 21:49:03,234 i18n.setup_gettext:110: ngettext = <bound method NullTranslations.ngettext of <gettext.NullTranslations object at 0x7ffbb6e64450>>

D: 21:49:03,234 i18n.setup_gettext:111: gettext_countries = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x7ffbb6cae4d0>>

D: 21:49:03,234 i18n.setup_gettext:112: gettext_attributes = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x7ffbb6e668d0>>

D: 21:49:03,234 i18n.setup_gettext:113: pgettext_attributes = <function setup_gettext..pgettext at 0x7ffbb5c71680>

D: 21:49:03,237 webservice._network_accessible_changed:291: Network accessible requested: 1, actual: 1

D: 21:49:03,241 webservice.set_cache:317: NetworkDiskCache dir: ‘/Users/jhwalker/Library/Caches/network/’ current size: 116.0 kB max size: 100 MB

I: 21:49:03,241 pluginmanager.load_plugins_from_directory:207: Plugin directory ‘/Applications/MusicBrainz Picard.app/Contents/MacOS/plugins’ doesn’t exist

D: 21:49:03,241 pluginmanager.load_plugins_from_directory:221: Looking for plugins in directory ‘/Users/jhwalker/Library/Preferences/MusicBrainz/Picard/plugins’, 0 names found

D: 21:49:03,242 ui.playertoolbar.init:91: Internal player: QtMultimedia available, initializing QMediaPlayer

D: 21:49:03,255 ui.playertoolbar.init:98: Internal player: available, QMediaPlayer set up

D: 21:49:03,476 tagger.main:980: Looking for Qt locale en_US in /Applications/MusicBrainz Picard.app/Contents/MacOS/PyQt5/Qt/translations

D: 21:49:03,477 browser.browser.start:78: Starting the browser integration (127.0.0.1:8001)

D: 21:49:03,484 ui.mainwindow.auto_update_check:1263: Initiating start-up check for program updates. Today: 2020-08-05, Last check: 2020-05-10 (Check interval: 7 days), Update level: 0 (stable)

D: 21:49:03,484 util.checkupdate._query_available_updates:90: Getting Picard release information from picard.musicbrainz.org

Looks like it hangs on network access - probably supposed to prompt for access to “network resources” or whatever it is that Big Sur has added.

2 Likes

Thanks for the debug output, this is very insightful. There is already an issue about this at

2 Likes

I don’t know exactly what happens and I have no Big Sur install available to test myself. I also tried to do some research, but could not find anything. But one suspicion would be that maybe Big Sur enables the app sandbox by default for an app. So I attempted to explicitly disable the app sandbox (see this commit). Could you give the following build a try and see if it launches:

https://s3.eu-central-1.amazonaws.com/artifacts.picard.uploadedlobster.com/MusicBrainz-Picard-2.4.0.beta3%2B356.189e354e.20200808081207.dmg

1 Like

Thank you for the response and the updated build - unfortunately, no, it hangs in the same way; i.e, it appears to launch but the main window never displays and when you check it shows, “not responding”.

1 Like

Did you ask Apple about this issue?

No, I haven’t.

I have 153 applications on my Mac, and 152 of them are fine :wink: so I figure it’s something about the way Picard is coded differently from all the rest.

So I reported it here, and will wait for a resolution. Given Big Sur will be out in about a month, I expect more than I will be looking for a fix soon.

Likely, yes. What we need now is someone fixing it. We currently lack someone contributing to Picard and developing on macOS. Currently most of the testing and fixing for macOS is done by me. And unfortunately Apple is an endless stream of trouble with all the changes they force on developers with every release. Also I have never seriously used macOS for a longer time and do 90% of my Picard development on Linux. The only Mac I have available is a 2013 Mac Mini, which is a rather slow machine. And until I update this to Big Sur (if it even will be possible) I have no way to test this.

So if somebody has some experience in developing for macOS and ideally also some experience with Python and Qt5 any help is more than welcomed.

Regarding the issue at hand it could be a packaging issue, but also an issue with either Qt5 or PyInstaller. Upgrading Qt5 to a current or future release could help, but also break compatibility with macOS 10.12 which we still try to maintain.

3 Likes

I’m no programmer, but I am testing Big Sur. I’ve checked out https://github.com/metabrainz/picard.git, followed the steps in INSTALL.md, and Picard does successfully build and run. (I don’t know how to actually make a .app at the end, but it’s fully functional running inside Python.)

I’m happy to try and test whatever I can to help… just bearing in mind I can’t actually code yet. :sweat_smile:

5 Likes

i was hoping Picard will open after some time…
But it was consuming all my memory overnight…

Big Sur Beta 5 / Picard 2.4.2

Bildschirmfoto 2020-09-04 um 11.06.32

1 Like

Any update on this issue?

1 Like

Not yet. We don’t know the reason for this issue and actually no one is actively working on this. It would really be great if someone with development experience on macOS and the ability to run macOS Big Sur would step up and debug this.

The issue PICARD-1858 will be updated if there is anything new happening.

4 Likes