Picard fails to save only some albums (Permission Denied) even though I have all permissions

Tags: #<Tag:0x00007f58fa7822d8>

I’m tagging my 3000-song-ish music library and fixing inconsistencies to my personal liking.
I’m having an issue where picard refuses to save some albums (see below) with a “permission denied” error. even though i have all my unix permissions set right.

below, confirmation that i have proper permissions.

That’s a Windows path name, so make sure Windows permissions are properly set.

Make sure the files themselves and the target directory are writeable and not set to read only or hidden. Can you create files at the target location using Windows Explorer?

the failed saves share the same samba location as the successful saves, i can create, edit, play, delete- everything, just fine from winexplorer.
permissions are set from the samba server, on linux, which takes the UNIX permissions.

Can you enable debug output in the log view and share a complete debug output of both successful and failing saves?

I’m currently saving and moving stuff that does save correctly, i will post results in half an hour ish.

as you can see i put them into the exact same directory.

i just double-checked and apparently there was the read-only attribute. which you -apparently- can’t see in ls -l on linux :slight_smile:

2 Likes

Glad you found it. Yep, you are basically dealing with two different permission systems here :slight_smile:

I actually don’t know how exactly Samba handles and stores the read-only flag. In general the read-only flag being set is a common issue on Windows. We have a open ticket about improving the handling of this (e.g. Picard could ask if it should write anyway, basically temporarily removing this flag)

3 Likes