Picard do not save tag on OS X El Capitan

Hello to all

Picard no longer saves the data, suddenly and apparently without reason because I haven’t touched anything.

I use Picard 1.4.2 on OS X El Capitan.

The error ogo says this:

I: 11:13:44 Plugin directory ‘/ Applications / MusicBrainz Picard.app/Contents/Resources/plugins’ doesn’t exist
E: 11:15:33 Traceback (most recent call last):
“Picard / util / thread.pyo” file, line 46, in run
File “picard / file.pyo”, line 210, in _save_and_rename
File “picard / formats / id3.pyo”, line 420, in _save
File “picard / formats / id3.pyo”, line 526, in _save_tags
File “mutagen / _util.pyo”, line 152, in wrapper
File “mutagen / _util.pyo”, line 122, in wrapper
“Contextlib.pyo” file, line 17, in enter
File “mutagen / _util.pyo”, line 221, in _openfile
MutagenError: [Errno 13] Permission denied: ‘/ Users / Alessio / Desktop / THE STYLE COUNCIL - Greatest hits / 01.Speak Like A Child.mp3’

for each file I want to save.

I have no idea what plugin he is talking about, since I never installed any

What could have happened, but above all, how can it be solved?

Thank you

The error isn’t related to plugins (it just says this directory doesn’t exist, but that’s purely informative)

It seems Picard can’t write to directories or files due to permission issues.
I also find weird you have spaces in path / Users / Alessio / Desktop / THE STYLE COUNCIL - Greatest hits / 01.Speak Like A Child.mp3

1 Like

The permissions of the folder are these

Alessio (Io) read and write

and file path is this
/Users/Alessio/Desktop/THE STYLE COUNCIL/01.Speak Like A Child.mp3

I really don’t understand why it suddenly stopped working

You don’t look at the correct directory!

/Users/Alessio/Desktop/THE STYLE COUNCIL/01.Speak Like A Child.mp3 is the path where Picard is trying to write.


The path is /Users/Alessio/Desktop/The Style Council

In the meantime I updated to version 2.1.3 and tried to rename the folder from “The Style Council” to “name” but still not save the data

The path it fails to save the tags to is /Users/Alessio/Desktop/THE STYLE COUNCIL - Greatest hits/01.Speak Like A Child.mp3. Please check both the permissions of this specific MP3 file and the folder where it is located in.

The permission dialog you showed is for Picard’s config folder, but that is not relevant here. Picard is denied access to write to the MP3 file.

Yes, that was it!

I edited the file-by-file permissions and now it works. Strange that it happened, in the past I saved many mp3s without problems

Thank you

1 Like