Picard Can't See All Drives on PC

Hi All,

I have been using Picard for some time now but recently upgraded to Win10. I was using Picard just fine earlier today then my PC rebooted after installing some updates (not sure what it updated).

When I first opened Picard after that, I couldn’t see any folders, just the C: drive with nothing under it. I closed the app and opened it again, this time as administrator. Beautiful, now I can see my C: and subfolders. However, I can no longer see my NAS drive in Picard even though I can see my NAS drive in File Explorer. Weird.

I tried closing and reopening the app a few times. No luck. Any ideas on where to look to fix this? My NAS is where I store all of my files. Thanks in advance!

That’s pretty strange. How have you installed Picard? Using the installer or via Windows Store? Dies it make a difference if you install it the opposite way (e.g. try the installer if you had used the Windows Store or vise versa)?

1 Like

Thanks for the quick response!

Before the Win10 upgrade, I had installed it via the installer and it was working great. Even for a day or so after the upgrade, it will still working fine. I don’t know if Windows redid the install to come through the store. I can try installing it via the store instead but if I do that, will I lose all of my custom settings, scripting etc.?

No, it uses the same settings and you can also install both versions in parallel and use them both. Maybe it is worth a try, but honestly I don’t think it will make a difference.

I have so far no good idea what could be happening. Just to be clear: This is about the file explorer on the left, right? And it shows you your C: drive only, no other drives or network folders, right? Has the NAS a drive letter assigned (e.g. E: or something) or do you only access it using the network share name (something like \\yournas\somename)?

I think the file browser would not show only network shares unless you have mapped them to a drive letter. If that’s not the case (or maybe there was one but it got lost), try in Windows Explorer to go to “Network”, right click the NAS share and select “Map drive…” or something like this. You can then assign a drive letter. This might cause the drive to show up in the file browser again.

If that’s not the cause workarounds are using the “Add files” or “Add folder” dialogs or using Windows Explorer and add the files to Picard using drag and drop.


Hello again. :slight_smile:

Yes, this is about the file explorer on the left side within Picard.

I installed Picard again via the MS app store to the same affect. I still cannot see my NAS drive.

I am able to see C:, D: (computer recovery drive, whatever that is) in the Picard file explorer.

My NAS drive is mapped as Y: on my PC and I can see it in Windows file explorer. Just to be thorough, I mapped the drive again as X and opened Picard. I cannot see the X: drive either.

To follow-up on your workaround, I added a folder (via Network and brought in one of my NAS folders. It added the files but still don’t see anything on the left. What I really need the drive to be visible is so I can run my file renaming script but since it can’t see the Y: drive, it can’t rename / move files.

Before Win10, I don’t recall having to run Picard as administrator and I was still able to see everything. Is the fact that I have to do that now in order to see drives indicative of an issue? Because if I don’t do that, I just see the C: drive but when I expand that, there is nothing below it.


1 Like

You don’t need the file browser for that. The file browser is really just kind of an additional gimmick to ease access to the files, but Picard is otherwise fully functional without it. Some users even never use it. Renaming / moving files is done when you save the files and renaming / moving is enabled and completely depends on the configuration you can do via Options.

Running as administrator should not be necessary at all. I would not recommend that. But I have also no idea what is causing this weird behavior for you. What do you mean with “before win10”? Did you just recently upgrade to Windows 10 and is was working before the upgrade, or was this broken after an update on your existing Win 10 install?

You could check whether the debug log reveals anything. Enable debug output int Help > View Error/Debug log, then restart Picard and paste the output here.

1 Like

Another question: Your drive Y: shows up normally in the “Add files…” dialog, right? Or also not?

Hi, my Y: drive does NOT show up in the Add files dialog.

Ok, that at least gives a bit of a clue: This dialog is the Windows default file picker dialog, it’s fully handled by Windows. If this doesn’t show your drives I suspect something has messed with your user’s permissions. Or permissions in general.

When I try to run my renaming script, which would tag my files, rename them and move them from a temp folder to my Y: drive, I get a red X with a message at the bottom of the window that says:

(error: [WinError 3] The system cannot find the path specified: ‘Y:\’)

By “before Win10”, I mean I was running Win 7 for a while. I just upgraded to Win10 on Friday and was using Picard just fine until Sunday. I came back to my PC on Sunday as saw that it was restarting.
Once it came back up, that’s when the Y: drive disappeared and I was not able to see any files under C: unless I run as administrator.

Here’s the output of the debug log when I run Picard as administrator. I don’t know what any of this means so hopefully, there’s no important information here:

D: 08:52:57,895 tagger.init:225: Starting Picard from ‘C:\Program Files\MusicBrainz Picard\picard\tagger.pyc’
D: 08:52:57,895 tagger.init:227: Platform: Windows-10-10.0.19041-SP0 CPython 3.7.9
D: 08:52:57,896 tagger.init:228: Versions: Picard 2.5.6, Python 3.7.9, PyQt 5.15.1, Qt 5.15.1, Mutagen 1.45.1, Discid discid 1.2.0, libdiscid 0.6.2, astrcmp C, SSL OpenSSL 1.1.1b 26 Feb 2019
D: 08:52:57,896 tagger.init:229: Configuration file path: ‘C:/Users/Scott/AppData/Roaming/MusicBrainz/Picard.ini’
D: 08:52:57,896 tagger.init:231: User directory: ‘C:\Users\Scott\AppData\Local\MusicBrainz\Picard’
D: 08:52:57,920 i18n.setup_gettext:65: unsupported locale setting
D: 08:52:57,922 i18n.setup_gettext:83: Using locale ‘en_US.cp1252’
D: 08:52:57,922 i18n.setup_gettext:85: Loading gettext translation, localedir=‘C:\Program Files\MusicBrainz Picard\locale’
D: 08:52:57,924 i18n.setup_gettext:87: Loading gettext translation (picard-countries), localedir=‘C:\Program Files\MusicBrainz Picard\locale’
D: 08:52:57,924 i18n.setup_gettext:92: [Errno 2] No translation file found for domain: ‘picard-countries’
D: 08:52:57,924 i18n.setup_gettext:108: _ = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x0000025228D929C8>>
D: 08:52:57,925 i18n.setup_gettext:109: N_ = <function at 0x00000252280D5798>
D: 08:52:57,925 i18n.setup_gettext:110: ngettext = <bound method NullTranslations.ngettext of <gettext.NullTranslations object at 0x0000025228D929C8>>
D: 08:52:57,925 i18n.setup_gettext:111: gettext_countries = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x0000025228D8F448>>
D: 08:52:57,925 i18n.setup_gettext:112: gettext_attributes = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x0000025228D92A08>>
D: 08:52:57,925 i18n.setup_gettext:113: pgettext_attributes = <function setup_gettext..pgettext at 0x0000025228A9CDC8>
D: 08:52:57,949 webservice_init_.network_accessible_changed:305: Network accessible requested: 1, actual: 1
D: 08:52:58,005 webservice_init
.set_cache:331: NetworkDiskCache dir: ‘C:/Users/Scott/AppData/Local/cache/network/’ current size: 89.9 MB max size: 100 MB
I: 08:52:58,006 pluginmanager.load_plugins_from_directory:207: Plugin directory ‘C:\Program Files\MusicBrainz Picard\plugins’ doesn’t exist
D: 08:52:58,007 pluginmanager.load_plugins_from_directory:221: Looking for plugins in directory ‘C:\Users\Scott\AppData\Local\MusicBrainz\Picard\plugins’, 0 names found
D: 08:52:58,014 ui\playertoolbar.init:92: Internal player: QtMultimedia available, initializing QMediaPlayer
D: 08:52:58,047 ui\playertoolbar.init:99: Internal player: available, QMediaPlayer set up
D: 08:52:58,360 tagger.main:979: Looking for Qt locale en_US in C:/Program Files/MusicBrainz Picard/PyQt5/Qt/translations
D: 08:52:58,365 browser\browser.start:78: Starting the browser integration (
D: 08:52:58,433 ui\mainwindow.auto_update_check:1320: Skipping start-up check for program updates. Today: 2021-03-01, Last check: 2021-02-28 (Check interval: 7 days), Update level: 0 (stable)

Any ideas on where to look regarding these permissions?

UPDATE: I am now able to see the Y: drive when I go to select a folder but I am still not able to see it in the Picard file browser. I’m not sure if it’s something I did or undid but I can see that part now.

Also of importance, in addition to only seeing the C: drive in the Picard file browser, I have specified a startup folder location that opens when I open Picard. However, that folder has sub folders under it that are visible in Windows but not Picard. Those subfolders have my music files (.flac) in them but they are not visible since the subfolders are not visible.

I’ve also stopped running the program as administrator. Any other ideas of things to check? Thanks!

UPDATE 2: So I opened Picard on my PC and stepped away for about an hour and 40 minutes. When I came back, all the drives were visible, i could see my music, default folder had all the songs in there. Everything was good!

My best guess is that it was taking its good ole time to scan the drives / folders? I’m not sure how long it actually took to come back but, like I said, it was back in 1 hr 40 minutes when I checked. I saw a few other posts where Picard could take a really long time when saving FLAC files. Is it possible the same is true when scanning them upon startup?

Anyway, for now, i think I’m good on this. Not sure why the long delay in displaying drives and folders in the Picard file explorer but it is working as expected. @outsidecontext THANK YOU SO MUCH for your insights!

1 Like