Picard 2.6 Beta

Tags: #<Tag:0x00007f511011a6a8>

We have a beta release of the upcoming Picard 2.6 available, please see the blog for details:

5 Likes

I’m the only one who can’t download the newest version?
I always get a strange “app selector” dialog box. (Tried in Google Chrome, FireFox, MS Edge).

1 Like

Download works for me here. What kind of dialog is this? Was this for the installer or portable version? EU or US mirror?

For the 64bit installer and the 64bit portable EU 2.6.0b2 versions.
The dialog appeared only once in Chrome & Edge, now a click on the selection just does nothing.
No reaction in FireFox too.

Both US versions seems to work now :exploding_head:

For me both worked fine, EU server & Firefox.

Thanks. I found the direct URL in the html source and downloaded it from there.
Must be some local setting problem… :face_with_monocle:

We have just released Picard 2.6 Beta 3, now with dark mode support on macOS and the ability to switch between dark and light UI on both Windows and macOS. For details see the blog:

5 Likes