Picard 2.6.4 available now

We have just published version 2.6.4 of Picard. This is a pure bugfix release, see the blog post for details:

There will also be a beta release for Picard 2.7 soon, which will bring quite some changes and new features.


I actually get the following error after clicking on the Download Picard button at https://picard.musicbrainz.org/

Not Found

The requested URL /pub/musicbrainz/picard/picard-setup-2.6.4.exe was not found on this server.

Apache Server at musicbrainz.osuosl.org Port 443

Please use the EU mirror for now. Looks like the US mirror has some sync issues. I checked if it was working just a short time ago before we published the new website, but I can confirm the downloads don’t work for me either currently. But I assume the US mirror will get synced eventually.


Issue is now solved. Download works fine from both (EU + US) mirrors.

US download for macOS still gives 404.

Edit: and Windows.

US mirror should now also have the files. Please let us know, if it still does not work for you.

Hi, my macOS runs on 10.13.6 so I have to opt for the ‘10.12+’ version of Picard 2.6.4, however the app once downloaded remains inaccessible and still prompts a message that it requires an OS of 10.14 or higher. I tried this for both the EU and US mirrors without success. I redownloaded Picard 2.6.3 through github and it works as intended thankfully.

Just to clarify: Did you maybe download the 2.7 beta version? Because I can reproduce what you describe for the 2.7 beta, but 2.6.4 works fine for me on macOS 10.12. I added https://tickets.metabrainz.org/browse/PICARD-2293 for the issue with the 2.7 beta.

1 Like

I am reporting this in case it is a thing…

Windows 10 PC. Loaded up three compilation albums, looked up CDs, fully tagged them, fingerprinted, etc. Hit save. Left them sitting in the Right Hand Panel. Left Picard open and running.

TEN DAYS LATER… I return to the PC to update the tags. Picard still open. I click on one of the releases… picard freezes, I heard hard disc rattling away, picard “whites out” Not Responding, then Pffft… gone. Vaporised. Crashed out with no error message.

Yes - picard had been running for two weeks. This PC is used for music playback and tagging tasks only. So sits headless and I remote access to it when doing tasks on it. Only thing it had done all week was run KODI and had VLC also open on screen for similar length of time.

Now this is actually v2.6.3 as I had started this tagging session a couple of days before but had lots of site editing to do to correct details on these three releases.

Just thought I’d mention it in case there is something leaky going on. Will install v2.6.4 bravely install the beta v2.7 and leave it sitting in similar state for another couple of weeks.

1 Like