Picard 2.5 is now available for download

We have released the stable version of Picard 2.5. Please see the blog post for details on the changes:


Thanks for another release! This time with a suspicious clustering of filename-as-tags-related changes… :stuck_out_tongue:


Yes, and indeed this is thanks to @scotia actually using this feature and reporting back :smiley: This also triggered me to look into the dialog more closely, make it easier to access (it has a keyboard shortcut now and you can place it in the toolbar if you want) and finally document it.

And if this release has a common theme it is probably fixing small annoyances and making small adjustments to the UI to make it more user friendly and more discoverable. Mostly triggered by discussions here, on IRC and the ticket system. So at this point thanks a lot to everyone who had feedback or questions on Picard. And a friendly reminder that everyone is welcomed to improve and extend the documentation :wink:


Hi, the Mac OS download says “No mountable file systems” when you try to mount the .dmg file. I get the same error when you download from the US & EU mirrors.

1 Like

What version of macOS are you running?


Please also verify the integrity of the downloaded DMG file. If you have downloaded it open a Terminal and run:

md5 ~/Downloads/MusicBrainz-Picard-2.5.dmg

Adjust the path if you have placed the file elsewhere. The command should output MD5 checksum of b0cf05354bae73bb7ada0cf26f891a43. If it is different the download is broken. In general the files from both mirrors are fine, I just checked them.


Picard 2.5 has problem with %_multiartist% . I’m using this command:

$if($and(%_multiartist%,$or(%compilation%,%_artists_album_additional_id%)),%artist% - ,)$truncate(%title%,70)

It doesn’t create artist name in filename, also with this command is the same problem.

$if(%_multiartist%,%artist% - ,)$truncate(%title%,70)

Rolling back to 2.4.4.


Yes, this has already been fixed, will be in the 2.5.1 release. This affects the %_multiartist%, %_pregap%, %_datatrack% and %_totalalbumtracks% variables.

1 Like

We have release Picard 2.5.1 with a couple of bugfixes and minor improvements over the 2.5 release. As this fixes a potential crash when loading directories without permission and fixes the issue with the %_multiartist% tag no longer being usable I recommend to update.

See the blog post for details on the release:


Picard 2.5.2 is now available as the next maintenance release of the 2.5 series. Another round of fixes, but also some new functionality:


I get the same message. The upgrade won’t mount.

I would retype the question, but @outsidecontext asked the same of @Halex212 upthread:

I’m running macOS Big Sur 11.0.1 and the upgrade worked fine for me.


@nosedocman See what @HibiscusKazeneko wrote, and also verify the integrity of the download


We have now released Picard 2.5.3:

As this release contains an important fix to a performance regression in Picard 2.5.2 which could badly impact saving many files or removing many files or albums it is highly recommended to update.

Overall this release contains much more changes than originally expected, including quite a few improvements to the usability. Unless you find some bad bug this is likely the last release for 2020!


Great! Thanks guys!

I followed the link, expecting a happy little DOWNLOAD button there, but the page currently looks a little bit weird to me?


I had to navigate back to the main Picard page to download it.
I agree, most of the blog posts up until this point have included a link so readers wouldn’t have to do this.

1 Like

And a suggestion/request for maybe next year?:

Picard has shortcuts available for several functions.
It could be useful that when you hover over a button such as ‘Cluster’, the tool-tip popup displays that a shortcut is available for it by displaying: ‘Ctrl+U’.