Picard 2.4 released

The Picard team is happy to announce that version 2.4 of MusicBrainz Picard is now available for download. See the blog post for details and download options:


Have tried to install 2.4 three times. Keep getting “Failed to Execute Script Tagger”.
So my old version is gone and I’m stuck.

What operating system are you using? Can you try starting Picard from the command line and post here any output it produces?

If you are on Windows you would open a command prompt and launch Picard with the full path, usually by entering:

"C:\Program Files\MusicBrainz Picard\picard" -d

See also this screenshot:

You can also try to remove all plugins in case one of the plugins is responsible for the issue. On Windows the plugins are located in your AppData/Local folder inside your user directory. You can access it from Windows Explorer by entering %LOCALAPPDATA%\MusicBrainz\Picard\plugins in the address bar.

You can also install older versions. All past releases are available at ftp://ftp.eu.metabrainz.org/pub/musicbrainz/picard/

1 Like

Running win 7. I have to leave for a few hours so I will run cmd when i return. Thx

Running Win 7 here as well, and the new version installed and runs fine.

I also am receiving error “Failed to Execute Script Tagger” as well. I am including as much information as I can find

I am running Windows 7 x64. I uninstalled 2.3.2, including user data and all plugins (even removed the folders from %LOCALAPPDATA% and %APPDATA%. There was no folder within %PROGRAMDATA% Emptied %Temp%

I had the following plugins installed in 2.3.2

  • addrelease
  • discnumber
  • replace_forbidden_symbols

“C:\Program Files\MusicBrainz Picard\picard” -d
Gives the following output
File “tagger.py”, line 19, in
File “picard\tagger.py”, line 974, in main
File “picard\tagger.py”, line 169, in init
File “picard\ui\theme.py”, line 164, in setup
File “picard\ui\theme.py”, line 164, in setup
File “picard\ui\theme.py”, line 102, in is_dark_theme
FileNotFoundError: [WinError 2] The system cannot find the file specified
File “tagger.py”, line 19, in
The syntax of the command is incorrect

1 Like

Looks like the registry entry is missing in previous Windows releases. Not sure how rdswift got past this.

1 Like

FWIW, same error on Windows 8.1 too.

edit: that was tested before seeing the above post!

I wonder if it’s because I have been running the source code for development and review. Maybe something was set then.

Very happy with the new preserve tags box. Thank you!

1 Like

For everyone having the issues starting Picard on Windows 7: @gabrielcarvfer has already identified and fixed the issue. As I currently don’t have a Windows 7 available it would be great if you could test the fix. I have uploaded builds with the fix for testing here:

If this is working well we’ll put out a 2.4.1 release.


2.4.1 fixed the problem, thanks to all MB wizards.


There are still some UI bugs in 2.4 / 2.4.1 relating to the performance changes. For example, if I have the release selected, then right-click on a field to use its original values, the UI does not render the modified tags until I de-select the release and re-select it. The same problem occurs if I delete a field from the release.

1 Like

Yep, this has already been reported and I just submitted a fix for this for review. See the following ticket:

Oh, another bug slipped through. I think I already have a fix, but I need to confirm something before.

@outsidecontext, I’ve found a very unintuitive behavior that seems like a bug to me. Is assigning a value to a field of an album supposed to overwrite original values of tracks with no files attached to them? It makes impossible to completely restore the original value of all items in an album.

1 Like

This sounds like a bug to me, too. I don’t think this is intended or expected behavior.

Found it. :slight_smile:

Update: not really, but almost. =X

Update2: really found it this time.