Picard 2.4 beta 2 selection focus issue

I tried to add an observation in the Picard beta 2 thread, but… Forum Computer says: NO!
“You are not allowed to post three consecutive times.”

Insert a big sigh here.
(this forum is really patronizing sometimes)

So, this is what I wanted to post there:

Probably not a real problem, but it feels like it’s breaking some Windows convention:

With the current beta release you can have entries highlighted in both the right panel and the bottom panel at the same time.
If e.g. you pressed Ctrl-A when focus was on the bottom panel, that highlighting remains when you next press an entry in the top right panel:


This is how it works in non-beta:


Oh God, I created a minefield of bugs… I will try to fix that ASAP.


The performance gained are worth the trouble :slight_smile: But that’s why we decided to go with an early beta release this time.

As a side not: I will be less responsive and less available for the next week or so. So please be all patient with responses from my side. But I read everything and will respond if I’m fully available again.


I’m sorry, that is not acceptable.
Please cancel all other obligations.


@hiccup, I’ve tried to reproduce the issue, but didn’t manage to replicate it. I initially thought it was due to some weird selection or focus shenanigans caused by my changes, but it doesn’t seem to be the case.

Trying to mess with the theming, I got a similar result due to accent colors in Windows 10 (I guess yours is blue and you’re using the light theme).

Made a few changes to make them different. Here is an example with the blue accent I assume you’re using.

Another example with dark theme with a purple accent.


I don’t believe I tweaked any funny stuff on my PC with regards to themes or colours.
It’s a very stable 1809LTSC edition, and this highlighting issue only shows with 2.4 beta, not with 2.3.2, so to me it looks like something has changed in the beta version.

Anyway, it’s not really posing any sort of problem that I am aware of, and if nobody else experiences it or is bothered by it, let’s not worry about it.

But theming is a thing added in the Picard beta (Picard-1704). Now it imports the Windows accent and uses it for highlighting.

I am seeing the same behavior you are, with the lower section not deselecting when selecting in the upper section. I’m using 2.4.0b2 and have no unusual windows themes. I don’t see it as a real issue, though. A copy seems to copy the expected information, and if I deselect an album in the top, the selection below adjusts to the what is chosen in the top. The selection in the bottom seems to follow the rows (e.g., if I select rows 5-10, it stays rows 5-10 regardless of the tags in those positions). Not proper behavior, but it really doesn’t affect or bother me at all.

1 Like

Is your Windows accent blue? Can you try changing it to another color just to confirm if the issue is what I’ve found? :slight_smile:

I tried several different accent colors. The selection colors didn’t change until I restarted Picard, but otherwise everything was behaving the same way. Colors didn’t seems to affect which items were selected when.

Thank you for testing. Restarting Picard to change colors is the expected behavior (pretty hard to change them on the go). The patch should mitigate the confusion with the selection colors.


Just to clarify: The issue is that with recent changes to theme handling in Windows both the active and inactive selection uses the same color. The actual selection works as normal, but the visual indication is not working as it should. Gabriel has a patch for this that’s looking good. I’ll merge it once I could actually run and test the code, which I can do sometime next week again.


Ahh - thanks! I couldn’t tell what the issue was, but now I understand.