Picard 2.1 Install bug or by design?

picard
Tags: #<Tag:0x00007f2a0055db20>

#1

I noticed when I installed Picard 2.1 that it tried to install in the C:\Program Files (x86)\

I thought that was odd being 64 bit program then I realized I had an old 32 bit version of Picard installed.

I uninstalled the old version and the Picard 2.1 version installed into the C:\Program Files\

Just an FYI. I’m not sure if this is a bug or by design.


#2

That’s already been reported as PICARD-1422.


#3

It is a bug. Keeps getting reported, but seems to keep getting left behind by design. There seems to be some confusion of trying to upgrade the current application… but it then just installs its 64-bit self into a 32-bit folder and attempts to use 32-bit addons… which don’t work.

This is a 64-bit application replacing a 32-bit application so it shouldn’t be trying to do that…

The more it is reported the better. :slight_smile: Hopefully something will get worked out. For now, the method to install is the one you followed. Uninstall the 32-bit edition first, then install the 64-bit one. That should make it pick up the correct path.

Edited to add a reply for @Freso : I do not have a ticket login to add to the ticket. I am sorry I can’t edit the code, I don’t have the skills. :frowning: If I could work out how to fix it myself, I would.

I have tested and reported this when asked. It has been explained in a few other test threads, including suggestions as to ways around it. It is just an installation issue, not exactly a “bug” in Picard.

All I tried to do in this post was to explain a way around it - uninstall the 32-bit version first and then manually check the path when installing the 64-bit one. The issue is caused by plugins. I’m sorry if you misunderstood my meaning here @Freso as I was trying to help.


#4

The more it’s reported, the more time developers will spend on having to say “it’s already been reported” instead of actually figuring out how to fix it.

If you know how to fix it, you should submit a patch or at least let the developers know how to do so on the ticket:

Closing this topic. Please direct any further insight into the issue to the ticket.


closed #5