Performance Issues


Page load times over at acoustID seem rather high - are there database issues again?

Seems like it, unfortunately. I attempted to submit fingerprints for a few tracks the last 3 or 4 days and they never show up. Picard logs say they were submitted successfully, but nothing ever lands on a recording’s fingerprint/AcoustID page.

I started to think it was something with my API key so I tried to generate a new one, which just threw me into an OAuth failure loop.

I’ve been noticing that submitting new fingerprints has been really slow for about the past two days. It’s not just you.

1 Like

Looks like the whole service is down. Look at the searches graph on Statistics | AcoustID

I have submitted 5 2Disc albums over the past few days. I’ve submitted the AcoustIDs for about 10 discs in total. I used Picard to submit them all. None are showing up.

What happened on August 1? There was over 3x the submission traffic. (Since then it looks like the servers have been spiraling toward downtime.)

May be it was me. I writing script that find releases without AcousticBrainz data, but with link to Bandcamp (there are approximately 180k of such releases), download it from Bandcamp streaming and submit to AcousticBrainz and AcoustID. Launched script several times for several hours between jul 27 and aug 1, and aug 7-9. Performance of script up to 140 releases per hour. Can’t say exactly how run was and how many releases script submit in which hour, have no proper logs. Totally between 27 jul and 9 aug i submit to AcustIID 12k releases, but submits were very unevenly distributed over time.

Primary target was AcousticBrainz, so i did not look and AcoustID submission statistic and did not think it can be noticeable (or destructively) on usual level of submits. I was sure (for no reason) that AcoustID gets more submits than AcousticBrainz, so because submit to AcousticBrainz is my bottleneck no need to worry about AcoustID.

I am really, REALLY sorry


I thought it was only me.
I tried to generate an API key for the first time and got locked into an OAuth failure loop too

I’ve been merging recordings in past few days, clicking on lots of AcoustIDs were getting slower and slower. Just now I got a Cloudflare warning instead.

It is also been noticeable that a week after I’ve merged a heap of recordings the AcoustID is still showing them all as separate. So there is a processing lag beyond just a server load issue.


Seems to not have been working for days now. Will not let me disable any of them.


Also getting cloudfare errors on the disable now. I can login, but not do anything once there.


Crunch… stats have now hit zero.

Not sure, but i think yesterday also was zero on graph. Now there 2724 and 2017. Some bag with graph. Day did not ended, stat for this day not calculated yet, but graph try display this day.

UPD: or not. submit fingerprints for Release “+2” by A Broken Sail - MusicBrainz few minutes ago by Picard, return code 200, but fingerprint not in database yet (

Logins and fingerprint submissions work fine for me now.

1 Like

API method submit return OK, but submission freez in pending status. And statistic graph still on zero

Asked on facebook

It’s an ongoing problem we are currently dealing with. The service works, but is unfortunately heavily rate limited.

We had one server going down, taking all the data on the server with it. All of that was replicated, so nothing was lost, but the service is running on tight budget, given that it’s free and one server out will cause things to overload.


That seems slightly confusing as lukz mentions here that it is not a financial issue?

Hope @lukz will write one more postmortem

1 Like

I think that was about money not solving the previous performance issue, because adding another server would not have helped, the application needed (or probably still needs) refactoring.


Tried to today for


Nothing up