Not all music put in gets reognized

Hey guys,

I’m very new to musicbrainz picard and honestly have negative understanding of technology. I have inherited a large music library I’m trying to run through the program little by little. I watched a tutorial online that made it look easy, but I’m experiencing a big problem.

Let’s say I put in 100 songs, I cluster them, then scan. What happens is that in the whole program, the left and right sides, I’m missing music. So actually in Picard is like 90 songs.

In essence Picard is not seeing some songs that I put in, leading to albums that are missing one song.

I looked everywhere in picard for these songs I put in, but don’t see them in there.

Please help if you can. Thank you

How do you “put” 100 songs to the left side of picard?
Drag & Drop?
Add Files?
Add Folder?

After “putting” the 100 songs, do they all appear on the left side before you cluster them or do you see only like 90 songs?

1 Like

If there are single files that do not load, please do the following:

  • remove all files from Picard
  • open Help > View Error/Debug Log
  • enable “debug” output there
  • restart Picard (makes sure we start Picard with debug output enabled and capture all the details from start), open that log again
  • attempt to load the unloadable files into Picard and check the output in the log view. Paste the output here, then we can help identify if there is an issue

If the files load just fine when you load it individually but not when you load all 100 files, then please repeat this process with all 100 files and again post the debug output.

Also how exactly do you load the files? There is an open issue with drag and drop of file paths longer than 259 character in total length on most Windows systems, these files just don’t get seen when dropping (see PICARD-2429 and PICARD-1779). Using the “Add files” or “Add folder” dialogs instead of drag and drop from Explorer is a workaround for this.


I drag and drop them. And they don’t appear on the left side before I cluster them.

Ok I will try this. I was dragging and dropping the files so the last paragraph you wrote might be the reason.