Newb issue regarding tagger script

picard
Tags: #<Tag:0x00007f23c2ae8840>

#1

Hi there,

I run Picard 1.3.2 on Opensuse Leap 42.3
I have lot of releases I can’t find in MB database. However I want to tag them as follow:
If discnumber is set, keep it as it is, if unset, set it to 1.
If totaldiscs is set, keep it as it is, if unset, set it to 1.
I wrote 2 ways to do it the same but both are not working.

Ver1
$if(%totaldiscs%,$set(totaldiscs,%totaldiscs%),$set(totaldiscs,1))
$if(%discnumber%,$set(discnumber,%discnumber%),$set(discnumber,1))

Ver2
$set(totaldiscs,$if2(%totaldiscs%,1))
$set(discnumber,$if2(%discnumber%,1))

Could you check this script.
Maybe the reason is not in the script itself but the script is not triggered because the tracks don’t move in the right pan. Could you let me know the basic?

Thank you for your help


#2

I have the “Disc Numbers” plugin enabled, and the only logic I need for disc numbers is the padding to 2 digits. It does include disc numbers if there is only one disc.

I don’t know if this is different on *nix; I’m on Windows.

Edit to add; Become an Editor! and add the information about the releases to the database. Once you’ve done that, you’ll be able to pull it back out as needed.


#3

Unfortunately, it’s not working.
I can’t find an answer to the basic question: What are the triggers to start the tagger script? Do you have the answer?


#4

I’m pretty sure the trigger for the tagger script is the loading of the data from MB. If I were you, I’d just use a stand-alone tagger like Mp3tag if you don’t want to use MusicBrainz.


#5

Done with a bash script using metaflac.

Thanks for your help