Need a hand ironing out my last few issues

so i have been working specifically within musicbrainz all stinkin day today and my brain is about fried and i figured i could use another pair or eyes to help point out some of the problems i am having. basically, after finalizing my file naming script and editing the settings/options and plugins, i run my music through and go to view it and notice a few things i want to change but cant figure out how.

first, i notice underscores in random places and dont want any underscores anywhere.
second, i have a lot of songs that are just singles, i have very few ‘entire albums’ and because of that, musicbrainz isn’t picking up on adding the songs to the same album if they belong together, instead i will have a file matched with ‘now thats what i call music…’ instead of the actual album it was released on.
third, i cant figure out how to not include the parenthesis if a date/year isn’t listed.
and last, i want to only include the album cover art and not a picture of the cd because the music player i use sometimes uses the cd picture instead of the album cover which is more familiar to look at.

here is the file naming script i am using:

%album% $if(%date%,($left(%date%,4)))/
$if($gt(%totaldiscs%,1),$if(%discsubtitle%,CD %discnumber%: %discsubtitle%/, CD %discnumber%/),)
$num(%tracknumber%,2) - %albumartist% - %title%

and i have the following plugins installed…

-add album column
-add cluster as release
-album artist ext.
-amazon cover art
-classic disc #
-collect album artists cover art
-feat. artist in titles
-fix track #
-load as non-album track
-non-ascii equal
-replace forbidden symbols
-smart title case
-stand. feat.
-the audiodb cover art

i’m not sure what else i could include but i’m pretty sure it has just been a long day and i’m overlooking something easy and another pair of eyes could point out what i need to do so if you are that pair of eyes, thank u for your help!

You’ve been using (MusicBrainz) Picard. And I’ll try moving this thread to that section of the forums.
As for “all stinkin day today and my brain is about fried” - this brings back lots of memories.
Just checking that you have made a complete back-up of your data?

Edit: The moving is beyond my super-powers. (I can type though.)


Heya. Your third question I dunno sorry :slight_smile:

Underscores are put in to replace characters not allowed by Windows in filenames.
Try something like:


(stolen from @outsidecontext, will replace the underscores with nothing)

In Picard, go to Options > Metadata > Preferred Releases

Drag the sliders around to your hearts content. In this case, compilation all the way to the left, and album to the right.

Is the album name in the existing tags? If so only use ‘lookup’, not ‘scan’, to match the files. Scan is checking for an exact audio fingerprint, so if your version of the song is a compilation version, scan will correctly match it to the comp.

I’m not sure exactly how you’ve set this up, but let’s cover some bases for embedded images or local images:

In Picard, go to Options > Cover Art
There you can tick the checkbox to only embed the front cover.

In Picard, go to Options > Cover Art > Cover Art Archive
For downloaded images, check ‘download only cover art images matching the selected types’. Then click ‘select types’ at the top right and make sure front is in the correct column, nothing else.

Also check that you’re removing existing images etc, in case the disc images are already embedded. Anyway, all the options you need should be on those pages.

Hope that helps


In addtion to what @aerozol wrote above: Since you have both and TheAudioDB plugins active, check the options for both plugins. Both will by default fall back to use the medium image if there is no cover. You can change it to either always download the medium image in addition to the front cover or never download the medium image at all.