Names of artists being automatically translated to English, even though I settings are set to a different locale?

Tags: #<Tag:0x00007f0504964168> #<Tag:0x00007f0504963f60> #<Tag:0x00007f0504963bc8> #<Tag:0x00007f05049639e8>


Hello. I have the setting for “Translate artist names to this locale where possible” set to Japanese, and preferred release countries to Japan, but when picard loads an album the artist names are in English. How can I get it to actually load the Japanese artist names?


Hi, Diaphontos.

I think the important words are “where possible”.

The Picard documentation for this Metada option says,

Translate artist names to this locale where possible: When checked, Picard will see whether an artist has an alias for the selected locale. If it does, Picard will use that alias instead of the artist name when tagging. When “English” is the selected locale, the artist sort name (which is, by Style Guideline, stored in Latin script) is used as a fallback if there is no English alias.

So, translating artist names is only “possible” where there is an alias for the Japan locale. I haven’t looked, but I expect there are very few such cases.

It would be nice if MusicBrainz and Picard was able to translate any artist name to any locale, but sadly it doesn’t have that ability.


Thank you. Turning it off fixed it. Strange though that having it on automatically changes the names of Japanese artists to English, instead of staying Japanese


Yes, that is strange. Maybe you have found a bug in Picard, in that this option isn’t consulting the selected locale properly.


Could you give links to a specific artist where this happens?