MusicBrainz Picard stopped working all of a sudden

I use this program all the time and went to use it today and the app is completely blank, I’ve attached an image for reference. I had it installed via Homebrew, so I tried uninstalling and reinstalling and that didn’t work. Then tried downloading it straight from the website and had the same problem? This happening for anyone else or just me? Any suggestions?

That’s pretty odd, never seen this before. Can you try running it from command line with debug mode turned on and paste the output here? If you use the official app download you can do this with running this from a terminal window:

/Applications/MusicBrainz\ -d

Of course adapt the path to the app as needed, the above assumes you have moved it to your applications folder. Not sure how homebrew installs it and how it is callable there.

It could be related to your configuration. In this case make a copy of the Picard.ini in $HOME/.config/MusicBrainz/ and then try to remove the Picard.ini and see if Picard starts then. If this is the reason I would be interested to get your Picard.ini for debugging. If you share this file just make sure to edit it in a text editor before and clear the lines starting with oauth_, as those provide access to your MusicBrainz account.