MusicBrainz Picard 2.6 is now available

We have released the stable version of Picard 2.6. More details about the changes and how to download it on the blog post:



When downloading from the Picard web site, if I pick the European mirror, I get this strange message, which translates more or less to : “Open Select an application? wishes to open this application.” In French the wording seems as strange as in English. The US mirror works fine.

That’s because the links to the EU mirror use FTP as opposed to HTTP. FTP was disabled in Chrome for all users since version 88:


Ah, and they didn’t think of using a clearer message! Thanks for the exlanation.

I don’t know how it looks like on other operating systems but that’s the message I see on Windows 10 and clearly it sucks :\

Hi, completely new here. I am trying to get a little control of the MESS which is my music collection. It is enormous and constantly growing but was started years ago by me with little or no knowledge about how to put music in folders correctly. Some of my music is missing in folders that are empty but others are in multiple sub folders which are almost impossible to find. There are a multitude of copies of the same music on several music players. One of which is MusicBee. Someone there recommended Piccard and said I should download the portable version. But when I did it did not ask where I wanted it stored. It was recommended that I PUT IT ON a D or E drive and in a folder labeled Piccard. Which I tried to do. So I am wondering if I need to download the installer as well as the portable version? Or is the portable version self contained. Any help or advice is much appreciated. Please understand that I am self taught on computers. I get around pretty good but may not understand certain terminology. It sounds dumb but I know what I know and I don’t know what I don’t know. Sometimes leading to not even knowing what question to ask. Thank in advance, Pamela

The portable version is self-contained, you don’t need anything else.

As to where this was downloaded this depends on your browser. Most modern browsers put downloaded files into your “Downloads” folder in your user’s home folder. Your browser should show the downloads somewhere. E.g. Firefox shows the downloads after a click on the small down arrow in the toolbar:


If you click on that folder icon it will open a file browser at the location where it placed the file. Other browsers behave similar.

1 Like

Thank you so much. That explains a lot

It’s funny how it offers you to open the FTP link with Chrome again.

I totally missed that they have now finally ditched FTP support completely. That sucks, especially as it offers such a bad user experience when you try to access a FTP link. Maybe we should just hide the FTP links in Picard’s website for browsers not supporting it. At least as a quick measure.

Small heads-up, Firefox will also disable FTP starting with version 88 (to be released on 2021-04-20) and removal will follow in version 90:


After failing to get the new ‘legal name’ variables of the ‘Additional Artists Variables’ plugin to work, I thought to do a clean install of the plugin. And now it works.
It seems that the auto-update/notify-new-version feature of Picard is not working for this plugin?
(I had 0.6, the new version is 0.7.1)

ping @rdswift

There is no Autoupdate for plugins ;( Only way to update a plugin is manually via Options > Plugins.

Yeah, I probably should have said auto-notification.
I am used to get notified of a new version of a plugin when I open the plugins panel?

Now I see. Yes, the latest published version is 0.6. While the plugin received an update recently we haven’t yet updated the website. Currently the website needs to be re-deployed to show the latest plugins. That’s not fully automated yet.


A casual question to others to see if they’ve experienced this, I’m not sure its a bug in Picard so I am hesitant to submit it as such.

With 2.6 (windows x64) I have had this issue that occurs. no error messages appear or anything, but after a few uses Picard loses the functionality of being able to drag and drop files and clusters within the two panels. Not drag and drop into Picard from external, only the ability to manipulate from in the program itself. I can highlight something, but if I try to move it nothing happens. I can scan and lookup tracks but if on the right it groups from 1 album into 2 versions, I cannot consolidate those two together because of this issue.

closing and restarting the application does not resolve the issue. rebooting my PC will fix the issue, but after several uses the issue will reoccur with nothing otherwise unusual happening.

anyone else experience this?

I haven’t experienced that here, running 64-bit Windows 7. Strange that a reboot fixes it, but not stopping and restarting the program.

1 Like

yeah, it is. that’s why I suspect it’s a memory issue or something with my PC, but I’m not having any similar glitches or errors in any other applications except this one.

Does anything show up in the log for Picard? You might also try disabling all plugins and see if that works. If it still fails, then we’ll know it’s something in Picard itself. If it works with the plugins disabled, you can then re-enable them one at a time to see which one might be causing the problem. Thanks.


We have released Picard 2.6.1 with bugfixes, performance improvements and some scripting enhancements. See the blog post for details:


Here is a confused feature\bug in Picard.

I have a four disc boxset I am tagging. It is a bootleg and each track has a Track number and CD number set. Each track is labelled “Piste 1, 2, 3, etc” and the album is “Album inconnu (21/08/2019)” with similar “Interprete inconnu” garbage in the Artist name.

I have punched SCAN to get some AcoustIDs, knowing it will be wrong, but dragged it back to the left to re-cluster as I know the album this is from. Cleaned out the wrong matches on the right, and used TAGGER to get the correct album on the right.

Now I have tracks on the left with fingerprints and AcoustIDs, and one album selected on the right.

Problem 1 - I am trying to use Drag and Drop to move each cluster to line up to the album on the right. It does not seem to want to read the track\disc numbers so I have some manual shuffling. NOT a problem as this is badly tagged.

Now I have it all lined up neat… and I spend some time on MusicBrainz updating some tags\details from the booklet.

Problem 2 - I return to Picard and make a BIG mistake. I hit REFRESH. ARGH! Why has my carefully hand sorted tracks now all jumped into CD1? Why did refresh reorder the tracks that were carefully hand placed?

I can make this album available via WeTransfer or something for testing. Or is it planned for Refresh to shuffle all the tracks on the right like that?

Note: the newly shuffled order seems to have no sanity to it. Now attached to track 1-01 I have tracks 1-01, 2-01, 2-14… it is weird

Note2: Why the SCAN step? Because I want to read the AcoustIDs as I am trying to clean up some other issues in the DB connected with this. Yeah yeah, I could have done all the fingerprinting later but don’t expect this weird head to do anything in what you think is a logical order :crazy_face: