Musicbrainz Picard 2.1 crashes while saving the 5th song

picard
windows10
Tags: #<Tag:0x00007f2a05675918> #<Tag:0x00007f2a0567b930>

#1

Musicbrainz Picard 2.1 crashes while saving the 5th song. In the task manager music brainz picard was stopped. Under 7 Win, it has always worked. i am now using windows 10 pro.


#2

Have you tried saving each song individually to see if it is only crashing on the 5th progressive track or track 5 and only 5 every time. this would help those trying to troubleshoot. to save each song one at a time click on the track then click save.


#3

It would be helpful if you can follow the steps outlined in Picard’s Troubleshooting guide to provide logs too.


#4

after a deinstallation with all personal files and new installation I can not start the program now.


#5

When you reinstalled it - what folder is it now running from? I keep seeing crashes and issues reported when the 64-bit application gets installed into the old 32-bit folder and tries to use incompatible 32-bit plugins.

Check the location - are you in C:\Program Files\MusicBrainz Picard\ or C:\Program Files (x86)\MusicBrainz Picard\? If the latter, uninstall again and reinstall to the correct path WITHOUT the (x86). See if that helps.


#6

To add to this, the best way to get some log output in case of crashes is opening a Windows Command Prompt and starting Picard from there with:

"C:\Program Files\MusicBrainz Picard\picard.exe" -d

This will print debugging output directly to the command prompt window with hopefully helpful information.

Yes, in case you upgraded from Picard 1.4 you should follow @IvanDobsky’s advise of completely uninstalling the software and reinstalling.

Just to clarify: The issue in this case was not the path, it was left over files from previous installation. While you are supposed to install 64bit applications to “Program Files” and 32 bit applications to “Program Files (x86)” there is otherwise no magic behind these paths, your software will just run fine from either path (or any other you install it to).


#7

I’ve tried everything now, everything deisntalliert and reinstalled at startup, just a circle turns and sas wars, the program does not open anymore. then I reinstalled the old version. but this is running after saving an album, it freezes after saving 1-2 songs.


#8

Go and specifically check that you don’t have anything in C:\Program Files (x86)\MusicBrainz\Picard\Plugins that is left over from another time. Ideally run the uninstaller again and go into both C:\Program Files (x86)\ and C:\Program Files\ and delete any MusicBrainz remnants you find. Then run the install again. That way no plugin can be hanging on and causing troubles.

The files that are locking up Picard - have they been tagged before? Are they your own rips or sourced from elsewhere? I have had buggy MP3 tags mess-up other applications before, though Picard is pretty hardy.

If they are older pre-tagged files, try running them through something else like MP3TAG. Maybe a corrupted tag.


#9

This is not about whether any mp3 tags are damaged, it is about the fact that I can not start the program even after many hours of work.


#10

Do you get any error when starting Picard? Have you tried running Picard from command prompt as suggested above to see if there is any useful error output before it crashes?


#11

no, no mistakes come. it turns a short time a circle and then nothing more.


#12


#13

On my Win10 box I uninstall 2.1.2 and then reinstalled to C:\MusicBrainz Picard\ like your example. (Only one drive in that PC, but other machines have it on D: and E: drives)

When I start I get this example of a clean log:

C:\Users\Ivan>cd "\MusicBrainz Picard"

C:\MusicBrainz Picard>picard -d

C:\MusicBrainz Picard>D: 16:04:38,933 tagger.__init__:196: Starting Picard from 'C:\\MusicBrainz Picard\\picard\\tagger.pyc'
D: 16:04:38,933 tagger.__init__:198: Platform: Windows-10-10.0.17763-SP0 CPython 3.7.0
D: 16:04:38,933 tagger.__init__:199: Versions: Picard 2.1.2, Python 3.7.0, PyQt 5.11.3, Qt 5.11.2, Mutagen 1.41.1, Discid discid 1.1.1, libdiscid 0.6.2, astrcmp Python, SSL OpenSSL 1.0.2k  26 Jan 2017
D: 16:04:38,933 tagger.__init__:200: Configuration file path: 'C:/Users/Ivan/AppData/Roaming/MusicBrainz/Picard.ini'
D: 16:04:38,933 tagger.__init__:202: User directory: 'C:\\Users\\Ivan\\AppData\\Local\\MusicBrainz\\Picard'
D: 16:04:38,965 i18n.setup_gettext:71: Using locale 'en_GB.UTF-8'
D: 16:04:38,965 i18n.setup_gettext:73: Loading gettext translation, localedir='C:\\MusicBrainz Picard\\locale'
D: 16:04:38,980 i18n.setup_gettext:77: Loading gettext translation (picard-countries), localedir='C:\\MusicBrainz Picard\\locale'
D: 16:04:38,980 i18n.setup_gettext:80: Loading gettext translation (picard-attributes), localedir='C:\\MusicBrainz Picard\\locale'
D: 16:04:38,980 i18n.setup_gettext:103: _ = <bound method GNUTranslations.gettext of <gettext.GNUTranslations object at 0x000001C8D3A7B198>>
D: 16:04:38,980 i18n.setup_gettext:104: N_ = <function <lambda> at 0x000001C8D33E4B70>
D: 16:04:38,980 i18n.setup_gettext:105: ngettext = <bound method GNUTranslations.ngettext of <gettext.GNUTranslations object at 0x000001C8D3A7B198>>
D: 16:04:38,980 i18n.setup_gettext:106: gettext_countries = <bound method GNUTranslations.gettext of <gettext.GNUTranslations object at 0x000001C8D3A80940>>
D: 16:04:38,980 i18n.setup_gettext:107: gettext_attributes = <bound method GNUTranslations.gettext of <gettext.GNUTranslations object at 0x000001C8D3A857F0>>
D: 16:04:39,027 webservice.set_cache:293: NetworkDiskCache dir: 'C:/Users/Ivan/AppData/Local/MusicBrainz/Picard/cache/picard/' size: 92288367 / 104857600
I: 16:04:39,027 plugin.load_plugindir:267: Plugin directory 'plugins' doesn't exist
D: 16:04:39,027 plugin.load_plugindir:292: Looking for plugins in directory 'C:\\Users\\Ivan\\AppData\\Local\\MusicBrainz\\Picard\\plugins', 3 names found
D: 16:04:39,043 plugin.load_plugin:347: Loading plugin 'Add Cluster As Release' version 0.7.2, compatible with API: 2.0
D: 16:04:39,043 plugin.load_plugin:347: Loading plugin 'Release Type' version 1.4, compatible with API: 2.0
D: 16:04:39,043 plugin.load_plugin:347: Loading plugin 'Copy Cluster to Clipboard' version 1.0, compatible with API: 2.0
D: 16:04:39,808 tagger.main:857: Looking for Qt locale en_GB in C:/MusicBrainz Picard/PyQt5/Qt/translations
W: 16:04:39,824 tagger.main:861: Error loading Qt locale en_GB
D: 16:04:39,840 browser.browser.start:69: Starting the browser integration (127.0.0.1:8000)
D: 16:04:39,902 ui.mainwindow.auto_update_check:1139: Skipping start-up check for program updates.  Today: 2019-01-31, Last check: 2019-01-31 (Check interval: 7 days), Update level: 0 (stable)
D: 16:04:39,902 webservice.ratecontrol.get_delay_to_next_request:109: ('musicbrainz.org', 443): First request
D: 16:04:39,902 webservice.ratecontrol.increment_requests:134: ('musicbrainz.org', 443): Incrementing requests to: 1
D: 16:04:40,402 webservice.ratecontrol.decrement_requests:142: ('musicbrainz.org', 443): Decrementing requests to: 0
D: 16:04:40,402 webservice._handle_reply:411: Received reply for https://musicbrainz.org:443/ws/2/collection: HTTP 200 (OK)
D: 16:04:40,402 webservice.ratecontrol._out_of_backoff:225: ('musicbrainz.org', 443): oobackoff; delay: 1000ms -> 1000ms; slow start; window size 1.000 -> 2.000

Looking at your log you don’t even get to the locale step. So a daft question - what language is your PC running in? Anything unusual about the setup?

Very weird this one… I’m not a dev but watch out for the Windows issues and try and help out a bit. Not seen many others with the app totally failing to start.

If I have read your replies correctly you say you have also tried installs after deleting all MusicBrainz folders. Did that include the two in the AppData folders as mentioned at the start of the debug? Old settings and old cache data in there. As well as plugins.


#14

Could maybe be related to the language settings as @IvanDobsky mentions. See also this topic:


#15

This latest behavior really looks like you encountered the same bug as in the other thread. It’s a strange one, I added a ticket at https://tickets.metabrainz.org/browse/PICARD-1463

As a workaround try deleting the Picard.ini at %AppData%/MusicBrainz. For me this is in the folder C:\Users\YourUsername\AppData\Roaming\MusicBrainz (replace “YourUsername” with your actual user name).


#16

Okay, it works. I have deleted the Picard.ini and the program started immediately and saves everything without crashing. Thank You


#17

I correct myself. The program crashes after the 5th song when saving.


#18

So we’re back where we started. :slight_smile: Again:


#19

I assume you meant you deleted the picard.ini ? If you still have it in your trash, it would be very useful for the devs if you could copy\paste it here.

Were you running in a different language like the other crash?

The debug log is needed again. Otherwise all help is guesswork.

You say “crashes after the 5th song” - is this the same album you are working on, or have you tried other albums? Is it always the 5th on every single album you give it? Even more bizarre.


#20

my language is German. It does not matter which album that is. Every other album breaks off after song 5. The break always follows after the 5 song when saving. I have already spent many hours in the work to find the mistake. It has always worked and it was a fantastic software under win 7. If it does not work here I am waiting for the next update or will use other software in the future. I am not a developer or supporter but end user. it works everything except save. I’m waiting for next update.