Music Brains 142 seems to corrupt files when played in Honda Accord 2018


#1

I got a new car and I wanted to add music via USB. This works fine… but when I run MBP on the files on the USB, it add cover art and corrects the tags (well it looks like it does). When I put the stick back in the car, the music plays 3-8 seconds then goes to next track, skips completely, displays unplayable file or displays a message USB is not responding [wait] [cancel].
Then the entire head unit runs slow until I pull the usb and restart the car.
The head unit is running Android Oreo and the stock music app. I cannot add another MP3 music app to it.
I also tried several usb drives with same result.
Also it seems to corrupt the internal data of the music app because when I reform the usb and put on the “untouched” mp3, it does scan the music anymore. I have to do a factory reset and the music gets read and works normally.
Some of my mp3’s do have cover art but something that MBP 142 does something that the head unit can’t tolerate

Any ideas?


#2

Sounds like the Honda is not following the MP3 spec properly.

I would experiment with narrowing down what it is that upsets the playback in the car.

Maybe the embedded art is of too high quality? A Multi-Megabyte image will cause problems for many audio players that don’t expect hi-res images. (I have seen this issue cause bugs on some Windows MP3 players)

Maybe there are too many tags being changed? Though the extra tags should just get ignored by the Honda.

Or daft things like incompatible characters?

Where do you get your original MP3 files from?

I would get a program like MP3TAG and use that to make a set of test files. Starting as the “untouched” mp3 files

Do you have any spec docs for your MP3 player? For example - which version of tags is it expecting?

Ultimately we need examples to be able to make sense of what you are seeing. Once narrowed down you can probably tell Picard not to do that thing that breaks Honda playback.