Multiple artists and genres as multiple tags

Tags: #<Tag:0x00007f7d004ae1b8>

Quod Libet supports this feature and the ID3 Tag specification allow multiple instances of the artist, genre, title, album tags without any problem.

In my collection that’s how I record multiple artists and multiple genres, I don’t use a semicolon or a comma within the same tag entry.

Is it even possible to instruct Picard to use separate entries of the same tag for multiple values?

For genres it is simple: In Options > Metadata > Genres leave the “Join multiple genres with” option empty. No joiner means it will be saved as multiple separate values. This is even the default.

For the artists you need some scripting in Options > Scripting. The simplest solution would be something like:

$setmulti(artist,%artists%)

Here is a more sophisticated version which also sets albumartist and corresponding sortname tags and also removes the then obsolete custom artists tag:

$set(_artists,%artists%)
$unset(artists)
$setmulti(artist,%_artists%)
$setmulti(artistsort,%_artists_sort%)
$setmulti(albumartist,%_albumartists%)
$setmulti(albumartistsort,%_albumartists_sort%)

Not sure if the sort tags actually make sense, for actual sorting one might still prefer having all as a single value.

2 Likes

I think I am having trouble with this.
setting_genre
As you can see, the genre is getting combined with ‘/’
genre result


version

Is that the right way to set multiple genres?

You are likely tagging MP3 files and have configured Picard to use ID3 v2.3. In this case multi-value tags are not supported. Best you try using ID3 v2.4, configure it in Options > Tags > ID3. If your player is supporting this well this is the better and more flexible option.

If your player has issues with ID3 v2.4 (which some still have), then you might be stuck with ID3 v2.3. In this case there is no support for multi-value fields, but you can configure the separator for your tags Options > Tags > ID3.

4 Likes

That did the trick, thanks for the help!

1 Like