More serious bug concerning edition groups

If you add a new edition with an existing edition group this edition group is not shown:

A duplicate edition group is created every time. I think there already a few dupes because I just noticed it now:

This should be fixed asap, I think.

1 Like

THanks! Indeed something is not working as expected, and I’ve replicated the issue on test.bookbrainz. I’ll investigate the issue in priority.

1 Like

Sorry @indy133 I spoke too fast, I replicated normal behaviour and thought something was wrong.
With more sleep I realize it’s working as expected for me (edition group with the same name is shown and can be selected):

If you can still reproduce the issue, could you please send the contents of your browser console as well as your browser name and version?
I’ll try to replicate the issue with that info.

It is also possible that this was a transient issue (maybe the search server was feeling tired?), which we should also handle.

Interesting, no changes here: esxisting group is not shown:

Google Chrome: Version 99.0.4844.51 (Offizieller Build) (64-Bit)

But if I’m the only one with this problem: I just use the “Search edition” function for now.
I just tried Firefox: same problem.

1 Like

Ah, I may have found the difference:

If I load this page (with the name added in the URL), it looks like the search for an edition group is not performed: Log In - MusicBrainz
Consequently no matching EG is shown.

Now if I modify the name —for example deleting the ‘s’ at the end, then typing it again— the search is performed and the matching EG is shown.

Can you please confirm you are seeing the same thing?

1 Like

yes confirmed.
When I change the title once, the edition group appears.

Thanks for the help debugging, that narrows it down nicely and I’ll work on fixing it tomorrow


So it turns out this is not a regression, and it never worked for editions (when we pre-fill the name in the URL).
Another issue is that the possible duplicate search (the one that shows up under the name) also was not triggered.
See for example: Log In - MusicBrainz
Same as before, if you add a space in the name, or delete and re-type the last letter or something, duplicate search is triggered.

I’ve got fixes out for review that should be merged soon:

Thanks again for reporting the issues you encounter !