Missing Genre Tags

picard
Tags: #<Tag:0x00007f29ffea1a70>

#1

At some point Picard stopped adding genres into the genre tag

Also, how can i separate Genres by a “;” instead of a “/”

Also Also, does anyone know of another alternative to Picard? i would like to try something else and then come back when Picard has less problems and i no longer have to browse/post to the forum.


#2

Do you have writing tags as genre enabled in options? Or did you previously use some plugin like last.fm? The last.fm plugins stopped working a while ago after some changes by last.fm. I don’t currently about the current state and which plugins have been adapted already.

[

Where do you see the slashes? I don’t think Picard writes slashes here, unless that changed recently.

If you are looking for something with MusicBrainz support, try Jaikoz

Just make sure our let us know what problems you face, otherwise nobody might know. For specific issues or feature wishes best is to open a ticket on https://tickets.musicbrainz.org


#3

I’m guessing that’s either in reference to how multi-valued fields are displayed in the bottom pane, or @billybag is saving ID3 v2.3 tags which don’t allow multiple values. For the first, it’s purely cosmetic and just how Picard and your music player happens to join them, for the second, there’s a dropdown in the options window, Tags page, that will allow you to switch to the semicolon if you are actually using v2.3 – you may want to switch to v2.4 if you don’t rely on Windows Media Player and their file explorer for playing music, and that toggle’s on the same page.


#4

Take a look at this page:
https://musicbrainz.org/doc/MusicBrainz_Enabled_Applications


#5

For the benefit of anyone searching for this issue (this thread appears in search results more readily than others), the culprit is probably that how Picard talks to MusicBrainz switched from XML to JSON, and the JSON method doesn’t yet support genre tags.