Metadata Genre Whitelist tag not ignoring excluded genres

Tags: #<Tag:0x00007fa5cdad7288>

I’m pretty new to the advanced features of Musicbrainz. In the past, I have used this platform to simply rename files properly and retag some basic metadata info. Now im moving on to advanced features to prep my database for my kodi library and I’ve come to the genre portion and can’t seem to get this quite right and haven’t found any forum posts related to my issue (close, but not quite).
I have a long list of accepted genre’s that I am using for inside of kodi, I have imported this list to Musicbrainz as acceptable genre’s to use else ignore the genre. The issue is that the whitelist does not seem to exclude the genre’s that I am wanting to exclude and instead writes them to metadata anyway.
I am using the Last. fm.ng plugin
my whitelist criteria
indent preformatted text by 4 spaces
-seen live
-favorites
-fixme
-owned
+70s
+80s
+90s
+a cappella
+acid house
+acid jazz
+acid rock
+acid-house
+acid-jazz
+acid-rock
+acid
+acoustic guitar
+acoustic pop
+acoustic rock
+acoustic
+action
+adult alternative pop
+adult alternative rock
+adult alternative
+adult contemporary
+alt country
+alternative & punk
+alternative country
+alternative folk
+alternative rap
+alternative rock
+alternative
+ambient
+americana
+ancient
+art rock
+arthouse
…Many other genre’s formated in the same way
Last genre entry to exclude all other genres
-*******

Example track: Arch Enemy - 05 Revolution Begins
Genre’s pulled in Metal; Thrash Metal; Viking Metal; Heavy Metal

I am wanting to exclude Viking Metal…all other genre’s are acceptable. However, it seems they are all included anyway. Oddly, If i test this in the playground section of the Metadata>Genre’s menu, Viking Metal is said to be excluded. So i don’t understand why this is happening.

I could just fix this one case and move on, But I’m wanting my entire library to stay inside of a specific set of genre tags for scalability purposes and I’m sure this issue is going to surface in other instances.

The Options under Metadata > Genre currently only apply to Picard’s built-in genre support, using data from MusicBrainz.

The genre plugins like Last.fm have their own options. I don’t know the Last.fm.ng plugins well, but it uses a configuration file instead of providing options GUI. AFAIK it uses a customizable whitelist to define allowed tags

Sorry for misleading, this would be the genre tag that is built in to Picard, I don’t believe that the data that is being read is the data that last.fm is pulling

update so i disabled the last.fm, ng plugin altogether to make sure that i was refering to the correct genre tag (i see multiple genre tags, I believe it’s because of the last.fm-ng plugin) Upon disabling the plugin and scraping the same CD, I see genre tags that have nothing to do with the album (electronc, trance, rock, jazz)…not sure if you’re familiar with Arch Enemy, but i assure you it’s none of those.

**update - I was able to edit the defaults.ini file inside the plugin to include only the genre’s that i am wanting and i believe this has corrected the issue. Thank you sir/ ma’am, you are a genius!
I have ton’s more questions about this program, but this gets me unstuck for now. Thank you

1 Like