Mess with the files


#1

hi everyone i did a mess with picard, it was the first time i used it and like a fool i loaded my library and pressed Automatic lookup button without clustering first and let it finish. Is there now a way to repair to this because i have many messed up files in here or silver disc icons while i have all the tracks of the disc.


#2

If you still have it all loaded in Picard, Just select all and drag everything back to the left side panel, so you can cluster. I’d suggest loading just a few albums, though, so you see everything is working as expected. Picard can speed things up, but it’s not great for actual automation; you need to keep an eye on what’s happening.


#3

unfortunately i had it all saved and closed. is it the same if i reopen again the library and move the files from right to left?


#4

If you reload from scratch, it will load on the left again but will probably move items to the right as it scans the mbids. But you can still bring them left again.

Since you’ve already saved it, fixing it will be more difficult, but not impossible. I suggest working by artist and seeing if you can find tracks that are tagged to the correct album, so you can drag other tracks onto that one. If it’s different versions of the same release, changing one version to the same as another one may automatically merge them. Hopefully that makes sense…


#5

thanks man, i’m going to try. i will let you know. :slight_smile:


#6

do i need to save after transporting to the left again or may i just go fine with clustering?


#7

I’m not sure I understand the question. There’s nothing to save when the files are on the left, and you can only cluster if they still have the same album name


#8

when i move them to the left, the disc icons still remain visible on the right along with 0/x numbering.


#9

Yes, and you can drag tracks to the ones you want to use, or delete the ones that are incorrect


#10

ah! so i move items to the left and then i can just delete the (empty) entries on the right! correct?


#11

Yes, you can remove anything on the right, the releases shown there are just sort of shells that you can plug your tracks into. Just beware that if you remove a release with tracks (actual files) assigned to it, the tracks will be removed from the interface, too.


#12

if i save all items uncategorized, when i reload the folder they keep on showing on the right…


#13

That’s the same issue as here: because you’ve saved the (incorrect) MusicBrainz IDs to the files, Picard will load those same albums and tracks when it opens them. If you right click and remove the “MusicBrainz Release Id”, “…Release Group Id”, and “…Track Id” fields in the bottom pane (as well as “…Release Artist Id” for good measure, and – only if it’s being connected to the wrong song entirely – the “…Recording Id”, “…Artist Id”, and “Work Id”), they should stop being misfiled.

Note, though, that because of how Picard works, the files will always go directly to the right pane if it knows what they are, unless the option described in that link is checked. What you want is for them to appear under something like “[non-album tracks]” rather than some incorrect album.


#14

i have removed all the tags with mp3tag.