Making tracks and discs numbered correctly in the same folder

filenaming
picard
discography
Tags: #<Tag:0x00007fe3d56e82a8> #<Tag:0x00007fe3d56e3aa0> #<Tag:0x00007fe3d56e3258>

#1

Hi everyone!
I am having trouble with disc numbering for the same artist. I am not sure if I am overlooking the problem but I can’t seem to find a solution when I change the file name, tagging etc… For very straightforward artists and albums, there aren’t any problems but for the albums with two or more disc in one album, I’m having difficulty keeping track of…well, the tracks.

Many of My collections have 2CDs in one and it looks like this:


Lay Up Under Me should be Disc 2 Track 01
.
.
.
Can it look like this in the folders/music player?

It would be great to have all of the discs in one Album folder while still numbering them as Disc 2 Track 01 instead of having two tracks with the same number

Right now I have no tagging or anything on and I just have it like this:
Album artist/Album/Title
Beyonce/4/1and1
I have tried discnumber, tracknumber, absolutetracknumber etc etc with no correct results

PLEASE HELP!! :cry:


#2

From your description it is not clear to me whether you have tagged your files with Picard already or not. If you do Picard should with the default naming script place your albums in a single folder. It will also add both the track number and the disc number in the tags.

However, not every player supports the disc numbers. If your player does not use the disc number tag it will still just use the track numbers, and there will be multiple first tracks for the album. One workaround is to use absolute track numbers, that is if the first disc has 12 tracks the first track in the second disc will have number 13. To achieve this use the short script described here:


#3

When I push the “lookup” button, nothing happens and when I “Lookup in browser” then click the green “tagger” button (Is that what I’m suppose to do, click the tagger button?) nothing happens. I scan a few of the files and then manually have to put some of them i the right place. I’m sot sure if this is what you mean but it seems some of the function in Picard aren’t working.

I added the script and it is still doing the same thing. I’ve played around with file naming and script that I have found from searching around but that hasn’t helped. And I’ve removed some scripting to suit My needs but :sob:

$replace($if($eq($left(%albumartist%,4),The ),%albumartistsort%,%albumartist%)/%albumartist%$if(%discnumber%,-CD %discnumber%,)/$num(%tracknumber%,2)-%title%,:,)

$if($ne(%albumartist%,),%album%/)$if($gt(%totaldiscs%,1),%discnumber%-,)$if($ne(%albumartist%,),$num(%tracknumber%,2) ,)%title%


#4

Hi @Ms_NMarie!

I’m not 100% sure if you’re problem is your player, tagging things with Picard, or Picard settings.
Have you looked at a page like:
https://musicbrainz.org/doc/How_to_Tag_Files_With_Picard
(edit: wow, that page is really outdated, sorry! But still useful I think)

A quick tagging overview:
If your files have no existing tags (or very bad ones), then ‘Lookup’ isn’t going to do much, it looks at existing tags and tries to match them (eg album name, track name, artist name) to the same tracks/albums/artists in the MB database.
‘Scan’ ignores existing tags and ‘listens’ to the track to match it to the same song in the database. Of course, this means it doesn’t know which album you want (as many have the same song), so you usually do have to do some manual matching/dragging and dropping.
‘Lookup in Browser’, I think you’re doing it right, after clicking the green button in your browser, you should now have that release appear in the right-hand pane of Picard (which you need to keep open), and then be able to drag and drop your tracks from the left into that.

That said, what playback program are you using? Changing audio player is probably the best option to be honest - Foobar2000 is what I use, and it displays everything perfectly without having to dumb down the tags.
Then you can just use default Picard settings and be done with it :slight_smile:


#5

I use iTunes mostly for now but as @outsidecontext said about the track numbers continuing from 12, 13, 14 etc, I don’t mind if it does that. I just want them in order in the folders. Thank You @aerozol I didn’t think to actually add it to My music player, I was so focused on the files.

It does order them how I like in the music player but not in the files.

I haven’t changed any settings in Picard accept for scripting and file naming. Took a look at the page and to the best of My abilities (that Picard allows) did everything for tagging but it doesn’t work. I am officially at a lost. It has to be something I am over looking to the smallest detail. Isn’t that how it usually goes? Haha. I’ll take the win and will try not to fuss too much over file naming, until I find a solution :slight_smile:


#6

[quote=“Ms_NMarie, post:5, topic:135941”]
It does order them how I like in the music player but not in the files.[/quote]
Sorry, I see you said you didn’t mind about tagging in your first post! My bad.

The default Picard settings should name your files like this (if it’s a multi-disc release):

1-01 - Song Title
2-01 - Song Title

At least, I assume it’s the default, because my files are like that and I don’t remember changing anything… Here’s my string which is possibly the default one! (emphasis on the part that I think you want)

$if2(%albumartist%,%artist%)/$if($ne(%albumartist%,),%album%/)$if($gt(%totaldiscs%,1),%discnumber%-,)$if($ne(%albumartist%,),$num(%tracknumber%,2) ,)$if(%_multiartist%,%artist% - ,)%title%


#7

Yes, that is the default for Me too. I’ve tried it all kinds of ways, with and without scripting, file naming, everything I can think of lol. Maybe it is My settings. I haven’t touched anything besides naming and script but Picard isn’t liking Me right now haha.

I’m not sure what it could be, I have looked around but I don’t want to fiddle with anything, Picard has wore Me out.
Oh! And I know the file naming is working because I’ve tried so many different strings and it has put that album in all kinds of places EXCEPT where I want it! LOL!


#8

Interesting… Could you please upload a single tagged (by you with your settings) 2-disc file for me?
A non © song of course :slight_smile:


#9

Umm…Hi @aerozol, could you say that in English please? I haven’t the slightest idea as to what you mean. Haha. I can’t “tag” anything, at least to what I’ve gathered. Whenever I ‘Lookup in Browser’ and would use the green tagger button, it wouldn’t work. I could try to upload the file that I’m talking about in the post?


#10

Yes please, up a file, one of the ones that you’ve ‘saved’ in Picard but isn’t showing up correctly in your folder.

I meant renamed not tagged sorry!
In your second screenshot you have saved some files (with the green ticks), saving them applies any settings you’ve got set, including tags. No need to use those green tagger buttons if ‘Lookup’ and ‘Scan’ are finding the right album already.


#11

It isn’t letting Me upload a file of any sort :unamused:


#12

We can try sort it through:
aerozol1@gmail.com

(if you want)


#13

In case anyone googles/stumbles across this:
The issue was the file browser not showing the actual file name - it was showing the ‘album’ tag. So the file was being renamed as wanted with the default settings :slight_smile:


#14

Although they might not be any more up-to-date, I soft-redirected the How-To page to the official Picard docs.