Lookup/Scan not working (SSL Handshake failed)

I’m using Picard to scan and tag my files but recently it no longer gives any results when scanning or looking-up the files. At first I thought it was because some of the music was only recently released or not in musicbrainz so I tried the EP Spit on a Stranger by Pavement and it still didn’t work.

I looked in the terminal and it printed this:

Failed to load module "xapp-gtk3-module"
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_get_peer_certificate
E: 21:34:10,059 /usr/lib/picard/picard/webservice/init._handle_reply:516: Network request error for https://api.acoustid.org/v2/lookup: SSL handshake failed (QT code 6, HTTP code 0)
E: 21:34:10,059 /usr/lib/picard/picard/acoustid/init._on_lookup_finished:100: AcoustID: Lookup network error for '/home/hellocatfood/Desktop/Pavement - Spit on a Stranger/Pavement - Spit on a Stranger - 01 Spit on a Stranger.flac': 'SSL handshake failed', b''
E: 21:34:10,059 /usr/lib/picard/picard/file._lookup_finished:826: Network error encountered during the lookup for /home/hellocatfood/Desktop/Pavement - Spit on a Stranger/Pavement - Spit on a Stranger - 01 Spit on a Stranger.flac. Error code: 6

Additionally, I tried searching for the album within picard and it returned this error

Following error occurred while fetching results:

Network request error for https://musicbrainz.org/ws/2/release?limit=50&dismax=true&query=spit on a stranger:
SSL handshake failed (QT code 6, HTTP code None)

Any advice on how I can fix this? I’m using Picard 2.9 obtained from the daily ppa but also getting the same result from the version packaged with Ubuntu 22.04. Output of picard --long-version

qt.network.ssl: QSslSocket: cannot resolve EVP_PKEY_base_id
qt.network.ssl: QSslSocket: cannot resolve SSL_get_peer_certificate
Picard 2.9.0a1, Python 3.10.6, PyQt 5.15.7, Qt 5.15.2, Mutagen 1.46.0, Discid discid 1.1.0 (compat layer from python-libdiscid 2.0.1), libdiscid 0.6.2, astrcmp C, SSL OpenSSL 3.0.2 15 Mar 2022

You have some incompatibility between the installed Qt5 and OpenSSL. This indicates that at least one of those components has been installed from a third-party source and not from the official Ubuntu 22.04 repositories.

The versions of PyQt 5.15.7 and Qt 5.15.2 indicate that those were installed from elsewhere. The official versions in Ubuntu 22.04 are PyQt 5.15.6 and Qt5 5.515.3.

I’d recommend you to check the following:

  1. Make sure you don’t have any third-party PPAs enabled that contain Qt5 or OpenSSL. If so, disable these PPAs and re-install the packages from the official Ubuntu repositories.
  2. Make sure you have updated your system to the latest version of all packages available from Ubuntu repositories
  3. Make sure you don’t use third-party package managers such as pip to install any of these components. E.g. installing PyQt5 using pip pulls in a custom build of Qt5.
  4. In general make sure you don’t have separate installs of Qt5 or OpenSSL anywhere in your library path. E.g. there should be no related libraries under /usr/local/ or $HOME/.local.

It turns out I did in fact have PyQT install via pip. Deleting that fixed my issue. Thanks!