Local mirror working ... how to get picard to use it?


#1

I finally got a local mirror working using the docker image available here: https://hub.docker.com/r/lsiodev/musicbrainz/
I can point my browser to localaddress:5000 and perform lookups using the web UI but cannot get Picard to use the local mirror. When I configure picard preferences to use my local mirror on port 5000 picard asks for username and password. I cannot find any documentation mentioning what credentials are to be used here.

A few things of note:

  1. using Picard for osx v1.3.2
  2. After performing an acousid scan which matches files with a release, Picard will not perform the release lookup without requiring credentials. I can perform a “lookup in browser” (from the right column) and get a browser to load the release page from my local server (url: http://192.168.0.2:5000/release/e44bfbc9-186c-414c-b77d-0e2bd0f8dd2b?tport=8000). Even with this I cannot get the release to show in picard after clicking the “tagger” link.
  3. “lookup in browser” does not work from the left column (pre-scan).
    URL: http://192.168.0.2:5000/taglookup?tport=8000&artist=Phil%20Collins&track=Don’t%20Let%20Him%20Steal%20Your%20Heart%20Away&tracknum=7&duration=289883&release=Greatest%20Hits%20CD1&filename=07%20Don’t%20Let%20Him%20Steal%20Your%20Heart%20Away.mp3
    The page indicates an error: read timeout at /usr/local/share/perl/5.18.2/Net/HTTP/Methods.pm line 271.

#2

I think the taglookup URL is performing a search and the search server is probably not included in that docker image, so it uses the search infrastructure of MB (there’s a setting somewhere in lib/DBDefs.pm for the search server that’s actually used).