ISRC submit OK'd, but ignored?

Tags: #<Tag:0x00007f05094a9d08>


edit: Never mind, spotted the stupid typo! isrc-list was spelled wrong. Weird to not get an error back, but will try again tomorrow—with the typo fixed.

edit 2: Was impatient, tried it again today—worked.

original, now solved problem below:

I made a webservice 2.0 request, POST to, with an authorization header and the following XML:

<?xml version="1.0" encoding="utf-8"?>
<metadata xmlns=""><recording-list><recording id="ea910427-aa79-481f-87c5-a4752198c1f0"><irsrc-list count="1"><isrc id="NLA507000523"/></irsrc-list></recording><recording id="4fb2c58c-b7e8-4109-af23-76198d656f90"><irsrc-list count="1"><isrc id="NLA507000522"/></irsrc-list></recording></recording-list></metadata>

and I got back a response with 200 OK and this XML:

<?xml version="1.0" encoding="UTF-8"?><metadata xmlns=""><message><text>OK</text></message></metadata>

but continues to show no ISRCs.

My POST appears to be correct according to and I get back a success message… but yet the ISRC doesn’t get added.

What am I doing wrong?


Based on the edits, this got fixed, right? The order of reading is a bit confusing.


@chirlu, @derobert had submitted a request with <isrc-list…> tag spelt as <irsrc-list…>.
The problem is that the Web Service did not raise any error in this case. :slight_smile:


Yeah, it’s fixed (at least, I got the ISRCs to submit). The web service should probably fail when given unknown tags in the MB XML namespace, but I guess it’s not checking the XML against the schema.

Sorry about the confusion—I put the edit up top so it’d be seen before trying to read through the XML. I’ve clarified it a little now, hope that’s clearer.