Is it ok to run sudo apt-get update on the musicbrainz server?

Tags: #<Tag:0x00007f05083123d8> #<Tag:0x00007f0508312248>



I’m not sure what happened but I got the latest server and build indexes and all was ok.

However i was told there was a lot of packages & updated that needed to be applied, so I ran the sudo apt-get update && sudo apt-get upgrade on the virtual server & it seems to have broken the musicbrainz search.

So I’ve had to start again and i’ve not ran it as yet in fear of breaking everything again.

Is it safe to run the apt-get update? Or even the apt-get dist-update/upgrade? Is there another process that I should be running?



Yes, that should be fine.

Which version of the VM are you using? It sounds like you are using an old one – there is a new one with a lot of improvements. If you are not using that, please upgrade to that version.


Would be nice if this would work. At least in my (officially not supported VMWare) environment such updates never worked. I gave it up.





Yes this was on the previous version, but since not being able to change the DB schema I waited for the latest version from this year & again I tried it and again I was no longer able to run DB search. I think it upgraded the Database software itself.

But I suppose if its not able to update then I won’t do it as I can’t spend hours and hours wasting trying to get it working.