Is anyone able to load this release in Picard?

musicbrainz
picard
Tags: #<Tag:0x00007f23c1e01a50> #<Tag:0x00007f23c1e01910>

#1

I’ve been trying to figure this out for a while, whenever I try to load this release into Picard it just hangs at [loading album information]. In the debug logs there are no errors it just stops after “Skipping cover art provider CaaReleaseGroup”. The same thing happens for the other release in this release group (the UK one). Does anyone else have the same problem or have any suggestions?


#2

Loads for me, I’m running Picard v.1.4.0dev3

:slight_smile:


#3

Loads for me too. Try refreshing it if it doesn’t load - if it’s still a problem, maybe try waiting an hour or two and try again. MusicBrainz’ servers are getting much more traffic lately than we can handle (we’re in the process of remedying that, but it’s not something that happens overnight), so if you try to load information from MB during peak times, MB will be slower, more sluggish, and more prone to giving error messages.

See also this post for more information:


#4

Some older versions of Picard aren’t able to handle this response from MB Web Service. Picard is showing status [loading album information] even after full response from server arrived. Whatever is the problem it seems to be fixed on the latest version. It seems to work fine after updating to 1.4.0dev5.


#5

Have you tried right-click-refresh/reload multiple times until full loading?


#6

“Older versions” meaning 1.3.2? :slight_smile:


#7

No idea. I remember trying some older version I had forgotten on my laptop. I tested with Wireshark and noticed that Picard was still showing [loading album information] even though full XML response from MB Web Service arrived long ago. I didn’t use that much time with it but remember that response looked perfectly valid. I also tried XML validator for it. I stopped investigating more when I noticed there was no problem with the latest version.