Installation problems

I am having some problems with manual installation, I tried to search for the problem but I did not reach a result.
I followed the installation instructions here: Installation — BookBrainz Developer Docs 0.1 documentation (
Use Windows 11

thanks for the help

Hello @n0urhan !

For the first issue, that’s news to me but I can replicate it locally. I’ll have to investigate to find a proper fix but in the meantime you can run npm run --legacy-peer-deps.

For the second issue, on Windows you can’t run bash scripts natively. I’m not on Windows myself but I think the easiest way is to set up Windows Subsystem for Linux (WSL) on your machine. See

This is the sort of reason we recommend using Docker to install everything; is there a particular reason you decided not to use Docker?

Good luck with the continuation, let me know if you run into other issues.

Ah, I also found this WSL related troubleshooting in our developer docs: Run docker inside WSL — BookBrainz Developer Docs 0.1 documentation

I installed docker and ubunto, after that I got this error and didn’t know what the problem was, should I install elasticsearch first? Do you have an idea of the problem? Thanks for the help

Looks like you already have something running on port 9200 on your machine, and when you start the ElasticSearch docker container it can’t connect to that port.

If you have ElasticSearch running outside of docker, stop it, then try running again.
If you run into the “waiting for elasticsearch:9200 …………ERROR: unable to connect” it may be because ES is taking too long to set up.
Try running command again if that’s the case.

If that’s still not working, you’ll need to look at the logs for elasticsearch to see if there are errors preventing the container from starting: docker logs -f elasticsearch

it is not logging anything

Does elasticsearch.yml file exist? chatgpt tells me that maybe the problem is from the configuration

I don’t think ChatGPT will be helpful in this case.

Looking at the output of docker ps it says the ES container was up for 52 seconds. It’s possible that the container is restarting over and over, but I would definitely expect some output logs with docker logs -f elasticsearch

Also looking at the docker ps output again, if you started everything together with, then we can see it took ES 2 minutes more than Redis and Postgres to be up and ready, which definitely goes over the timeout we set in (that “waiting for elasticsearch……”).

So let’s try again and run You’ll probably get the same failure.
Then run docker ps until the ES container is marked as up and you are sure it’s not just restarting over and over, then run again, hopefully that should do it.

Unfortunately it did not work

Hm, not sure what is going on then.
Grasping at straws here, but maybe giving the ES container some more time to boot up might be a good idea; i see there it’s been up for 24 seconds; if it took two minutes to start it could just be extremely slow.
Maybe waiting a minute or two before running again would give it some time to be ready.

Barring that and with no logs, I suppose your next step would be to run the ES container by itself and not in detached mode, to see if you see logs in the container directly: docker-compose up elasticsearch

No idea why it is stopping as soon as it starts, and without and error code either :person_shrugging:
Maybe try what is suggested here? Docker container exiting with code 0 & no logs - #4 by dliappis - Kibana - Discuss the Elastic Stack

I think the problem was from memory because my RAM was only 4GB, so I went and bought an extra 8GB RAM and installed it. The site is up and running now.
Thanks for your help.

1 Like

I am very excited to contribute to this project and apply to GSoC`2024