Installation error during update: can't write libcrypto-1-1.dll

  1. I had Picard 2.10 installed and it gave me the update notification so
  2. I downloaded picard-setup-2.11.exe from the site
  3. tried to run the installer without exiting picard and got a warning that it was running so i quit it and restarted the installer (wasn’t included at first)
  4. Hit next to uninstall and all that, didn’t change anything.
  5. It uninstalled but for the installation it gave me this error:

Error opening file for writing: C:\Program Files\MusicBrainz Picard\libcrypto-1-1.dll Click Abort to stop the installation, Retry to try again, or Ignore to skip this file.



I’m using Windows 10 version 22h2 (build 19045.4046) sv-SE. Only antivirus is Windows Defender and that didn’t say a peep.
I haven’t actually troubleshooted this yet, I haven’t even tried pressing ignore because thought I should post here before I do.

There are two possibilities here:

  1. The file has some file permissions that prevent removing. Check the files permissions in the properties dialog
  2. More likely the file is in use. If it is in use by a running process it can’t be removed or overwritten

Again if it is in use there might be several reasons.

  1. The file is in use by a running picard.exe. check the task manager and make sure no picard.exe is running. If it is close it. Then remove all files left after the uninstall in C:\Program Files\MusicBrainz Picard\
  2. The file is in use by another application. If you have e.g. put C:\Program Files\MusicBrainz Picard\ into you %PATH% variable it is well possible that an unrelated application also using this DLL loads it from the Picard install directory instead.

In both cases you might also solve it by simply rebooting your PC. Afterwards again remove C:\Program Files\MusicBrainz Picard\ and try the install again.


Thanks for the help!

I did try to install it with the program running at first but then i got the warning to close it and then i retried, forgot to say that in the first post.

I tried rebooting and got the same error, tried to delete the folder but got an error saying it’s in use… Looks like i got some general troubleshooting to do.

In this case you need to figure out which process is actually using the file. This answer might help:

1 Like

Also check whether you have the Picard install directory in you %PATH% environment variable. The environment variables are somewhere managed in control panel under system or such (don’t have a running windows to check right now). If it is then removing it from %PATH% and rebooting might also prevent whatever process is using that file to use it again.

If the directory is not in the path it’s a bit strange and I’m indeed curious which process is using it.

Tried removing the files instead of the folder and got a specific error that it was used by NVIDIA share…
nvidia share error
Didn’t expect that…

I do use Geforce Experience and Shadowplay to capture videos sometimes but I didn’t have desktop capture enabled.

I went into the settings for Geforce Experience and disabled the in game overlay and then I could delete the files. :raised_hands:

Thanks for the tip about the tools, I tried using this tool but turns out explorer could do it for individual files.

I checked the global path and the picard folder was there… maybe i tried to automate something at some point.


Thanks for confirming. Yes, you likely had some reason like easily running the Picard.exe command.

The DLL handling in Windows can really mess things up. In the past we also had multiple cases where Picard was loading the libssl DLLs from other locations and that leading to crashes or such, despite all efforts to make sure Picard is loading the bundled versions.

And this obviously also can happen to other programs which end up loading DLLs from other places. If there is some incompatibility between the DLL Picard ships and the one Nvidia has bundled this could also lead to e.g. Nvidia Share to crash.