Import from lastfm does not work

this happens when I try to import listens from on brave browser, linux. There’s no error on import option.

1 Like

I tried to import listens in chromium, it worked!
there are a lot of browser specific bugs I’m noticing with musicbrainz (like I can’t login in firefox), It would be awesome if they are fixed.

I haven’t used Brave, but I assume it has built in adblocking based on common adblock lists? Several adblock lists will block (I have no idea why) which is the API site ListenBrainz connects to when importing. You could try disabling any adblocking functions in the browser and trying again.

Also I haven’t experienced any login issues with Firefox, so I’d again test disabling any addons you have and try again. That or check your cookie settings as maybe you’re inadvertently blocking cookies required to keep you logged in. If that fails try with a fresh Firefox profile in case some other settings in Firefox are causing the issues.

You are right, Brave adblocker was the culprit in this case.
This should probably be added somewhere in the documentation.


Made a ticket: [LB-1276] import adblock note - MetaBrainz JIRA