Huge interface elements (solved)

Tags: #<Tag:0x00007f9ad97216b0>

Hi!

Once I launched picard and was surprised at the huge interface elements. What is the reason for this?

MusicBrainz Picard 2.2.1
Ubuntu 18.04.3 LTS

This looks like some HiDPI issue. Can you give details on your monitor and desktop environment setup? Also check if you have the environment variables for QT_AUTO_SCREEN_SCALE_FACTOR, QT_SCALE_FACTOR or QT_SCREEN_SCALE_FACTORS.

From the looks of it I would say it is for some reason using the HiDPI version of all graphics even if it shouldn’t. If this is an actual HiDPI setup try playing around with your desktop environments scaling options and the above Qt environment variables. Currently there are quite a few issues with Qt’s HiDPI scaling.

I can only partially test this myself since I don’t have a HiDPI display. But on my GNOME I got something a little bit like your screenshot by setting QT_SCALE_FACTOR=2 and QT_SCREEN_SCALE_FACTORS=2. In this case setting QT_SCREEN_SCALE_FACTORS=1 (or not setting it at all) should help.

3 Likes

Thank you for the tip. Now everything is fine.

My monitor has this configuration:

xdpyinfo | grep -B 2 resolution
screen #0:
  dimensions:    1920x1080 pixels (508x285 millimeters)
  resolution:    96x96 dots per inch

I added
export QT_AUTO_SCREEN_SCALE_FACTOR=0
to ~/.profile and restart session.

1 Like