How to Install Missing python module (macOS, aubio)

I’m on a Mac running “High Sierra” (10.13.2) and I get the following error on Picard start-up:

E: 09:50:45 Plugin 'bpm' : Traceback (most recent call last):
  File "picard/plugin.pyo", line 301, in load_plugin
  File "/Users/RayD/.config/MusicBrainz/Picard/plugins/", line 30, in <module>
ImportError: No module named aubio

I followed the directions for installing aubio from their website, but I still get the error in Picard on start-up.

I have the same problem and i use Windows 10.

My Picard freezes/hang up on a look up for files. And i can not go to the preferences to see that any plugin make problems.

I’ve cleaned the cache and i reinstalled picard. but it doesn’t work. i can not use picard because on every 2. or 3. file it will be hang up or freeze

Hi the BPM plugin was only tested and supported for Linux. I will have a look at possible instructions for OSX and Windows 10.

Aubio can be installed on mac with:

brew install aubio --with-python (

I’ve done that, to no avail. The BPM plugin still won’t work (same error msg ensues). MixMeister BPM Analyzer does, though.

Picard for macOS bundles Python with the app and does not use the system wide Python install. This is why it can’t find your aubio. It’s basically the same situation as on Windows.

I currently don’t know if there is an easy workaround. One option would be running Picard from source.

1 Like