How to include work-level-rels in web service API for a large release?

Tags: #<Tag:0x00007f9cfdf8d170> #<Tag:0x00007f9cfdf8d0a8>

I set up a local musicbrainz-docker server, to tag classical music file using Picard & classical Extra.
If a release has many tracks or media (I’m not sure what is the constraint), the web service API doesn’t include work in the API response.
For example,
http://musicbrainz.org/ws/2/release/788e89aa-10a5-4524-bcfb-bcbf92d10a27?inc=release-groups+media+discids+recordings+artist-credits+artists+aliases+labels+isrcs+collections+artist-rels+release-rels+url-rels+recording-rels+work-rels+recording-level-rels+work-level-rels

This response doesn’t have work relationship in the recording.
How can I change this to include work relationship, even if a release has a large track count?
I mean, changing my own local server setting.

Regards.

Hi!

You want to change this number, or change the code to not set a max:

3 Likes

Hi.

I increased the size to 3000. I confirmed the server response includes the work relations for the previous example.

Thanks.

1 Like